Herelink Boot Animation Customisation

Hello Everyone,
This topic is created due to problem that I have been facing while trying to customize herelink remote unit’s boot animation through OEM image flash method. I followed under given steps:

  1. Downloaded and extracted required image files : simg2img, img2simg, Remote Unit: oem_ru_base.img, Air Unit: oem_au_base.img.
  2. Created a raw image of oem_ru_base.img by command : ./simg2img oem_ru_base.img raw_oem_ru_base.img
  3. Created a directory oem and mounted created raw_oem_ru_base.img over this created oem directory by command : sudo mount raw_oem_ru_base.img oem
  4. Now I entered inside mounted directory oem and then I went to media directory.
  5. From there I copied folder to another location and extracted it there.
  6. Then I entered inside the extracted directory bootanimation and found that there were two directories there by the name : part0 and part1.
  7. I already had the images that I wanted in my custom boot animation with same resolution and same orientation, thus I renamed all the images as names that were given to image that were loaded at boot animation and replaced them with my images.
  8. Now I created a zip file for bootanimation folder in which I have changed the image.
  9. Now the file that was present inside media directory in oem directory is replaced with that has been customized according to my need.
  10. Now I checked the permissions of file and found that there were write rights too for it, so I removed them by commad : sudo chmod a-w as only read only rights are needed to be provided to it.
  11. Now I created an app directory inside oem and inside that I created a directory of my application that I am installing in herelink using OEM method.
  12. Inside the directory of my app I pasted the apk file and libraries required by it.
  13. Now I umnounted the oem directory and all the changed were reflected back to raw image that was used at the time of mounting.
  14. Now I created a sparse image for updated raw image using command : ./img2simg raw_oem_ru_base.img oem_ru.img
  15. Now used the command : adb reboot bootloaded to enter static boot state with fastboot on the screen.
  16. Now I flashed the image in herelink’s oem direcotry using command : fastboot flash oem oem_ru.img
  17. Image flashing was successful but when I rebooted the device the UI was inverted and no boot animation was displayed.

Can someone look through the approach that I have taken and rectify me if there are any changes that I need to make in the process that I have followed.

1 Like

Hello Sir, Can you please help me with this topic.

please post your modified zip file for us to check

Hello @Michael_Oborne,
Here is the file that I have been using to change the boot animation : (202.6 KB)
In this zip file, I was just trying to modify the boot animation to blank screen.

the zip file should not have the first directory as bootanimation, you should open the zip file and see part0 and part1 folders

Hello @Michael_Oborne,
I did what you asked me to do, but the result was still same. After the boot animation is completed, I got an inverted UI over my herelink device.
Updated bootanimation folder : (201.2 KB) (1.4 MB)

Hello @Michael_Oborne,
The zip folder that has been provided above did work for me, but can you please explain what were the changes that you did in it.
And also even after changing the boot animation when we reboot the device, we get cubepilot’s logo at boot screen. Is there any way to remove that too.

compress the zip file using “store” ie no compression

I am encountering the same issue where after flashing the oem image the herelink display is in portrait mode but touch commands are in landscape mode. The boot animation is also not visible. @Michael_Oborne Would you be able to look at my boot animation file as well. I have followed your instruction to zip with no compression but still no luck.

Please post the file

@Michael_Oborne The file size is a little big to fit the cubepilot max upload limit. I have put a google drive link instead.

@Michael_Oborne I accepted the access request

you have the same issue as the last one.

the store/compressed looks fine… ie its store.

the issue is that you have a extra folder level in the zip. when i open the zip i see a folder bootanimation. this is incorrect. i should see part0 part1 and desc.txt

I’m guessing the process is to select the individual files then zip instead of putting it into a folder and zipping that?

duno what OS your using.
i just select them all and click add to zip

Thanks for your advice man. I use MacOS and Ubuntu. Figured out a way to do the zipping reliabily. Also is there a way to change the cubepilot logo during initial start-up?


If you want the initial static logo to change, and a full custom OTA update process for your company (to keep your system up to date with all our features) we offer an OEM program.

This allows you to focus just on your app, leaving the background maintenance up to us.

Feel free to have a chat with us if that suits you

I’m having the same issue where it boots into portrait mode as Chandruth mentions above. Any tips on how to fix it? We tried to model our boot animation exactly after @Michael_Oborne example. (3.0 MB)