Herelink Firmware Update problem

is it necessarily like that? You always want to make it difficult for users. Why not to do this online? Between producer and users?

1 Like

I’ve got two Herelink. I tried to update both ground unit with the license key that I got from my local reseller (Robotshop). I am not able to register with both. I successfully flashed them, established a wifi connection and setted the time. Each time I try to enter the two license key I was given, a pop-up tells me that I cannot register. I’ve also tried the different regions, don’t know if it changes anything… Is there anything I am missing? Any idea?

Please send a message to @sidbh with the picture of the serial number on the back of your controller and the key you were given.


So after many times trying and reflashing the unit and still no luck. I tethered it with a USB cable to my surface and it went right through. Apparently even though it connected to my router and I could see data usage, it doesn’t like directly connecting to my TP-link. Currently it’s downloading the update. Hurray… thank you all.


Great news.

1 Like

@Hughes_La_Vigne we are not getting any verification request from your end, can you try via different network.

Very strange, I used the same network with my laptop and my cellphone without any problem, but it seems that the Herelink remote controller can’t access internet throught it. I used another one. Problem solved, thanks for the follow-up.


Tried to do the update on my herelink and followed the instructions and the flash screen, I think, went to quick. it did not show the same things as in the video. and when it reboots it does not show the set up screens. And I couldn’t find the update system tab in the area it it supposed to be. any help would be great.

Are you using Windows or mac ?

Windows you need to be on Win10 64 bit

If in windows try installing the android tools and trying again

I’m using Win10 64bit

When I did the flash program the. Screen went really fast for me too, The first time but if you do it a second time in a row it should go through the unpacking and for the air unit I actually had to do it three times. I had to click on the flash program the first time it flashed, the second time it unpacked and the third it installed.

I have done the same process about 5 times now and no luck. I must be missing something. when the ground controller reboots it goes to a white screen for a second and then loads QGC
I followed the video, but I can’t seem to get the Beta tab at the top of the instruction screen to give me the new FW .

The beta tab is now gone. The correct firmware is now on the main page.

here is a screen shot of the flashing process.


@K_Hunsaker Maybe try running the flasher program from a different location, i.e. copy to different folder and try again. Or try running as administrator.

tried both of those, also tried a different computer, still Win10. did not work.
Are there settings on the Herelink device somewhere that might be blocking this? is there some way to check the settings with a known unit, or new factory unit? could we have done something that is causing this to be blocked?
Can I do a factory reset and try again? or will that remove the QGC and original control settings?

Did you install the android driver on the other computer ?

I think so, when I plug in the herelink the usb reads the device. is that what you are referring to?

The issue you are seeing is totally unrelated to the Herelink device. Its a file permission issue. Which directory in Windows are you running the program from?