Herelink has paired status, Solex & QGC waiting for vehicle connection

Title says the main issue, updated the software last night and entered the product key and setup. Used the Herelink app and was able to pair the air unit, also setup the calibration for the joysticks, however both the Solex and GQC apps show that there is no vehicle connected.

Pair state: Paired
Controller signal strength: M: -63dbm, S: -66dbm
Uplink Rate: 1-4kbps
Uplink bandwidth: 16500kbps
Fly Distance: 50m (hasn’t moved, but assuming this is just GPS drift)
COuntry: US
Video Sharing: Enable

Is there something I’m missing or any ideas here?




No change to the physical setup of the serial port on your autopilot?

And of course, have you completely turned everything off and back on again?

You updated both the air unit and controller?

Updated the controller last night and the air unit this morning if that makes a difference.

I haven’t been able to pair the two units since I recieved them a few days ago, updated the software to see if it works. Only thing connected is the +12v power to the reciever, no outputs connected. I’ve power cycled a couple of times with no luck.

To get the vehicle connection in Solex or QGC, you need to have a valid telemetry link with your vehicle. You can’t have that connection if you don’t plug any output on your air unit.

1 Like

As stated the connection you are seeing is for your telemetry link you your flight controller. If you don’t have it connected when you can’t connect to it.

Oh, that’s obvious isn’t it, cheers! I thought that the dual antenna on the herelink air side was a transceiver rather than just receiver.

I’m currently grabbing the SBUS data out and parsing it, and there’s no change when I move the joysticks. Could this be an error on the controller/air unit side, or highly likely my side?

Have you calibrated the sticks. Tbh we need a little more info on your setup as it’s not standard.

The telem port and radio is two way but it’s to the UART port from the GS.

The sticks are calibrated and everything on there Herelink app appears to be configured.

My original understanding is that the SBUS was one way and just showed RC channel output and that the UART was two way onto the Pixhawk or other MAVlink communicating flight controller. I now realise that of course QGC shows that no vehicle is attached because the reciever is receiving data but there’s no flight controller/vehicle connection.

Currently the setup is as follows:
Groundstation running Herelink app w/ up to date software

Air unit powered and the SBUS connected to an ATMEGA2560 thru an inverter w/ and example script reading the channel info.

The goal is to link the air unit to a BBB via mavlink and for it to output channel data to a CAN bus, with telemetry data (battery %, sensor data, etc) going back to the controller unit. Video will then also be displayed via the groundstation.

Had the exact same problem. Dropped the serial baud rate from 921 to 115 and now it’s fine.

Did the update paired the receiver and made the calibration. I really appreciate the new setup documentation that’s now available, it is well done!

But the problem I have is that Solex does not connect to the vehicle. QGC connects right away, faster than before I feel. Video link and Mavlink no problem.

But nothing with Solex. I closed QGC, activated “Advanced mode” to try different vehicle type settings, but also nothing, also no video though radio status is linked. Any suggestions?

Have you tried rebooting and trying Solex with out opening QGC ?

Yes, all shut down and did not touch QGC, Solex still does not find anything. Just “Looking for vehicle…”

Any settings I can check or post? In the beta QGC needed an UDP connection, but now it works without. Does Solex need any config in that regard?

After the update the APP solex connects perfect and everything is perfect, streaming video connectivity with a drone, but after a few minutes the video connection disappears and a message appears on the screen


this with all the cameras, charged battery and everything correct.

is it normal that you are doing this video disconnection?

What camera are you using and are you on input 1 ?

Also try force closing QGC from the App menus in settings if it’s running.

This is being worked on and it should be massively improved on the next update and it’s been discussed and worked on directly. It appears it’s very camera specific at the moment.

1 Like

I work with gopro hero 7 black ok friend, yes and tried to force the application but it still offers that failure, I have to restart everything when this happens.

yes input 1

My baud rate is already at 115, I’ve updated, paired, calibrated etc… The system was working fine and the next morning I started it up and I get waiting for vehicle connection.

Where did. you drop the serial baud rate…? I did that via Mission Planner and no results for me?

I have this is issue as well, it was all working but then I updated to here 3 and recalibrated the compass using the Herelink and QGC, I now get the message QGC waiting for vehicle connection (Solex will not connect either). I get the telemetry and when I plug in my PC into the cube and run mission planner I see the sticks bars move when I move them. All the plugs seem to be in place, any ideas?

Also, I’m on the latest firmware and software around

Re-flash and updated the Herelink firmware software, paired ok, LED1 not lighting up. It was working fine up until installing Here 3 GPS and doing compass cal that succeeded, after reboot of system got this.

I have now re-install the firmware on the cube and restore old here 1 gps amd config, herelink now works. Has any one got a clue what went wrong I need to install the new Here 3

Re-installed Here 3 and went through config etc, seems to work now