Herelink Map problem

#1

Hi, I can’t load any map on my herelink unit. Anyone know about this issue and could help me?

1 Like
#2

do you connect to a wifi? you will need 5Ghz wifi to get internet connection

#3

Thanks for reply, i have 5 ghz network but my herelink unit don’t see the my network? Should it be seen?

#4

Your network is probably a 2.4ghz if you can’t see it

#5

I’m pretty sure that it’s 5 ghz. I have an asus ac68u. But i can’t see the network. What can cause this?

#6

I solved it. Even i’m not sure how i solved it but it is working. Thank you.

1 Like
#7

I have the 5G Wifi connected but I still don’t get any map loaded.
Neither can I download the offline map.
Should I have to connect to the receiver to load the map?
I restart the Herelink many times and still have the same problem.

#8

Have you tried switching the map provider? I think I had a similar issue but when I switched provider it worked.

#9

I try Bing and Google with Satellite or Streetmap.
None of these work.

#10

Have you checked location settings

#11

Sure
I try “Device only” and “High accuracy”
Still can’t work.

#12

What internet connection do you have?

#13

I’m having the same issue , is there a solution yet ?

#14

also same issue here. wifi connected but none of map providers shows maps

#15

also same issue here. wifi connected but none of map providers shows maps

#16

Switch map provider then switch back to desired. It’s all it takes to fix

1 Like
#17

That doesnt help, i have imported maps from pc qgc so its working only that way fir me

#18

No doesn’t help.

#20

Hi to all, I opened this thread long ago but discovered something recently that can help some people. Herelink units may not detect the local 5ghz wi-fi due to DFS channels. If you change the settings on your router NOT to include DFS channels, your herelink unit should see the network. I’m not sure but these channels are used by weather radars or something.

#21

Correct.

1 Like