Herelink "No serial ports available"

I’m having an issue connecting the Remote with the Air unit. The devices pair successfully. On reboot they sometimes connect, and while downloading parameters the connection is lost and cannot be reestablished. Most often however they do not connect at all.
In the Comm Links tab on the Remote, when I try to create a new connection I get the “No serial ports available” message in the “Serial port” field. When I try to connect through said connection I get an error message: “Error on link Serial Device on. Error connecting: Could not create port. Try again.”
I suspect this is the reason behind the unstable connection I’m seeing.
Both Remote and Air units are with firmware 0.2.2.
Here are a couple of illustrations of the issue:

Is the air unit serial port connected to one of the Cube serial/telem ?
If yes, what are the settings of this Cube serial port ?

Best,
Julien

The Air unit is connected via UART to a Navio2 board. Arducopter is configured to use the UART connector /dev/ttyAMA0 for telemetry

Situation has developed a bit. While browsing the forum I found this topic: Link keeps dropping and decided to try the firmware versions that are proposed there. With them the remote and air units connect, I start getting telemetry data, and about 15 seconds later I get a “Connection lost” message. This happens every time I restart the drone. So far after losing the connection it was reestablished once and lost again in a few seconds.

It seems an issue with the Navio. Unfortunately i didn’t know this board so i hope someone could help you.

1 Like

So you think this behaviour is caused by wrong data being received by the Air module from the Navio board?

Possibly. The serial of the navio is well configured ? ( baud : 57 / protocol : Mavlink 1)

Yes, it is. I played around with different configurations and this is what the way it actually connects. While connected I get telemetry data, and the remote unit tries to fetch the parameters. At some place during parameter download, the connection gets lost. It’s not at the same spot, sometimes it’s in the beginning, sometimes near the end, but it’s always during parameter download.
I also tried manually updating QGroundControl to the latest stable version and to the latest daily build, but the result is the same with any of them.

Have you tried turning off GPS on the ground station on Herelink

Yes, I found this hint a couple of days ago and it was one of the first things I tried.

Update: Issue solved. Thanks everyone for your help and suggestions :slight_smile:
So basically @Julien was right - the issue was with the data received from the Navio board. However this was just the tip of it. The Navio2 sits on top of a Raspberry Pi and basically relays its UART interface. So we did some testing and tinkering and found out that the Raspberry outputs not only the Arducopter data to the UART, but also the console output. And the Herelink Air module receives a mix of both. Once this was discovered the fix was easy - simply disabled the console output to the serial interface in raspi-config and voila - connection is now steady and all is great. Still cannot get video to work, but I suspect it’s a faulty camera issue. Later will be able to test with a different one.

1 Like

Did i won something ? :stuck_out_tongue_closed_eyes:

Thank you for sharing your investigations and the solution !