Link keeps dropping

#1

Got a herelink unit with a strange link problem.
If both remote and air end are inside a room/building, the link between them is steady , streams video etc and overall seems to work fine.
If I take both air and remote units outside, within a few seconds the link data rate drops out from ~60kbs to 1kbs and then the units disconnect entirely. Restarting the units does not help.
Updated firmware to 0.22 on both remote and ground end. Tried powering air unit at 5 and 8v via fixed switching BEC or adjustable BEC.
Tried rebinding, tried auto/manual freq. mode, tried reducing/increasing bandwidth for upload/download, tried 3 different outside locations and 2 rooms, different antenna placing on a quad(nothing else transmits from that quad, not even 2.4g radio receiver).
See a video here:

I’d say faulty hardware but I cant explain either why indoors the link is solid and never drops out in 5-10 minutes of test, while outside out of 1 minute 50 secs is disconnected.

#2

what firmware you on ?

#3

0.22, previously i don’t know but the unit is a recent sale, 1 month old.

#4

we have same problem with recently bought herelink. indoors it works well even i can go with controller to other rooms and signal keeps steady. once i go outside connection starts to drop and gets lost. Video signal is working controller also. but unit shows communication lost and i dont receive telemetry. it regains from time to time for very short period. yesterday i made upgrade to latest version both air and remote units but this didnt solve problem

#5

Guys getting this all I can suggest is triple check all connections and if it’s the same speak with retailer and it really sounds like some hardware issue and they would need to go back to be checked.

The question is if it’s on the ground or Airside but Profi would need then hardware back in the retail channel to get this diagnosed.

@philip May be able to suggest something more.

#6

connections are ok there is nothing you can make wrong there. coz indoors it is working without any problems and outside it starts to drop. sounds really odd but this is what i get. there is connection between air and remote because see video and can control drone. but it says connection lost. it was bought from foxtech week ago and sent direct to my from HEX HK

#7

The serial cable is factory made, can’t be from that. The power supply can’t be, tried 3 different power supplies.

#8

Ohh hold on.

So it’s not loosing total link, your only loosing telemetry connection,

Does RC connection drop to in the craft ?

Try connecting craft to mission planner outdoors and then look at what drops

Video Y/N
RC Sbus Y/N
Telemetry connection Y/N

If it’s just Telem then it’s connection or issue with the build. Possible bad connection on the Telem cable end, try it in a different Serial port first and see if it’s the same.

If it is it could the the Telem connector crimp as I have seen one with a connection on the crimp.

Sorry the way I was reading is you are loosing total link

#9

I have not actually checked if the video feed works outside, or if the sbus part keeps working. I will try and inspect more careful, I took the link lost for good.

#10

Its not about the cable thats for sure coz inside it works well even if i try to shake cable or conectors. I will try on another pix 2.1 tomorrow on another copter to see if its same problem

#11

Ok sorry it’s probably best to start again on this as I said above

The first thing is to understand what is dropping so it is all ie Video,Sbus and Telem or just Telem

When it drops is the Air end LED on, what colour ?

If everying is dropping the FC should enter failsafe and show, no RC input, you will get no telem data on Herelink or Video, if this is happening make sure there is no Wifi getting involved or any high power radio where you testing, next whats the power setup for the craft and how is the Air End powered, whats the LED doing.

Best way to test this is try connecting craft to mission planner outdoors on laptop and then look at what drops in that,

Connect camera and check Video
Check RC input via Sbus
Is telemetry connection ok, remember all of the prams and data you see is over the serial bus, RC control is separate.

If your only loosing telem then look at what changes outside, do you 100% have the serial port settings correct, is it dropping because of GPS lock or something else, there has to be a trigger.

What else it attached to the FC, try it as a standalone only that connected and nothing else, Aldo try Serial 2.

Further to this can you post a complete spec list so FC, GPS and list everything else thats attached to the FC in every port, also how are you powering the Here Air End, Is there a BEC involved ?

Hopefully we can get this nailed down, posting the spec will help regardless. even some pics may help too.

#12

Hello, back from further testing.
The setup rig is as follows:
pixhawk 2 cube
pixhawk 2 power brick(powers pixhawk only)
5v UBEC for the air unit and a servo
sony rx100mk2 camera for hdmi video source
all of them on a plastic board

Video feed and RC link work flawlessly even when the remote unit shows connection lost(tested with a servo attached to a barebone pixhawk.) There seems to be reasonable ground based range.
The telemetry side however drops out outside within seconds of exiting a building. Inside, even on the test bench all the links work with no problems, for an unlimited amount of time.
It seems to me like a bug of qground control.
Running 0.22 firmware.

#13

2 pixhawks tested, tested at default 57600 baudrate and at 115200 baudrate. Cable between the air unit and telem1 port seems fine.

#14

This is so strange, honestly makes no sense unless something is changing.

Really strange.

@philip I seen ones gone back for this possibly wait and see what the score is ?

#15

Do you loose all signals or telemetry only? On mine i loose telemetry only and controls and video works ok

#16

Mine does the exact same thing! But only outside, and there is no gps connected to think that may upset things.

#17

tried on another carrier board and cube. did not help

#18

@sidbh

#19

@Gedis, can you try the following test firmware? It contains older version of QGC. Just to check if upgrading the QGC caused an issue.
Air Unit: http://firmware.cubepilot.org:81/TestFW/HereLink_old/AirUnit_TestFW1.tar.gz
Remote Unit: http://firmware.cubepilot.org:81/TestFW/HereLink_old/RemoteUnit_TestFW1.tar.gz

#20

Meanwhile I got my replacement unit and under identical outside conditions the units work fine. Didnt test airborne yet, but it looks good so far.