Herelink radio problem

(Pau) #1

Hi everyone,
This is my first post as I recently purchased my Herelink station.

I’m trying ti use it in a boat with this setuo:

-Pixhawk Cube
-Herelink
Bluerobotics T-100 + Basic ESC’s

Main problem is that the trhusters doesn’t spin.

This is the parameter list extracted from Mission Planner
pauG.zip (4.1 KB)

Pixhawk firmware: Rover 3.5.1
Herelink has QGC development master 2019/04/26

In the Radio menu, throttle keeps in that position. When I push forward in increases but when I press backward it also increases.


Channel monitor from 9 to 16 are blinking
There’s also a problem with the flight mode parameters as you can see on the pop-up message.

That’s all I noticed that could be irregular.

Thanks in advance.

(David R. Boulanger) #2

I gave you my 2 cents worth over on the Ardupilot site.

#3

Link for the rest of us?

#4

When posting here and at ardupilot, please post a link so the conversation can be followed rather than having two separate conversations

(David R. Boulanger) #5


This is the link I think.

(Pau) #6

Hi,

Continuing with some issues trying to solve with no succes.

Throttle seems to be trimed at 1102 pwm. (lowest calibration point) that’s neutral point, thruster doesn’t spin, I can move forward but not backward.

radio%20mp

Any Idea?
Thanks in advance

#7

In QGC on HereLink, you can set the throttle type to having reverse

(Pau) #8

If you mean this option, is already enabled but it doesn’t work.

(Ian ) #9

Can you post a video of the throttle stick full movement

You may need to perform the hidden calibration for the hardware. It’s in the Cube pilot docs section. .

(cristina) #10

I had the same problem and I solved it this way
Hope this can help you