Herelink RC failure

Assalam O Alaikum Everyone,
I am using herelink as video tx and as RC with cube orange. But the RC connection is not stable. Every 10 seconds it shows a message of connection lost, it reconnects after a few seconds and same process repeats. I have updated the firmware of radio control, but the problem remains unresolved.

Hello,
You said you have updated RC firmware, did you do the same with the airunit ?
Have you tried pairing the airunit and the RC again ?

Yes, I updated both. Moreover, there is no issue in pairing RC with airunit , The video stream and Telemetry data are working fine, the only issue I’m facing is when I use it as a controller. In QGC the radio icon doesn’t light up also it doesn’t show the RSSI status of the radio.
It displays this error message (Parameters are missing from firmware. You may be running a version of X firmware QGC does not work correctly with or your firmware has a bug in. it. Missing params: 1:MNT_RC_IN_ROLL, 1:MNT_RC_IN_PAN, 1:MNT RC IN TILT)

Oh, I think I did not quite get your problem.
You are able to connect to your cube, download parameters, see telemetry and video, but not control the drone using your sticks ? Did you configure your sticks on the Herelink ?

Found this regarding the missing parameters problem :

I don’t think this message is related to your problem

Can you connect the autopilot to Mission Planner > Setup > RC calibration and see how is the RC signal?

Yes exactly, the sticks are not working. Regarding the configuration, the sticks are already configured on1st four channels of S-Bus.

Yes, I have done it. when communication is regained the radio signal on the mission planner responds accordingly with sticks. As soon as the communication is lost the radio signal on mission planner does not reponds.

Please contact your reseller for RMA.

Ok :+1:

I have changed the RC channel stream rate from 2 to 4 Hz in QGC, Mavlink, telemetry stream rate (ardupilot only). Dont know how but it saved my problem…