Herelink Unit suddenly stopped to send Telemetry Data

Hello guys,

We had a strange behaviour with a herelink kit this week. This kit stopped sending Telemetry Data for the tablet, and only video stream and RC Channels were working properly.

I tried several things to catch the problem: changed the Telem Cable, changed the Serial Port on the Cube that was sending MAVLink 2 Telemetry Stream, forced values to SRX_ Parameters on Ardupilot, made an android factory reset on the tablet and tried to pair another tablet, but none of these things made it work.

Finally, on the last hour of the day, we tried to plug a USB Cable on the Air Unit and made the update process, besides the fact that the air unit and tablet were already on the latest stable firmware version, and then after the update process on Air Unit, the Telemetry data came back to life.

Anyone experiencing similar problems with herelink kits? I am worried about this misbehaving because this UAV operated lots of hours and then suddenly this problem appeared. I would like to know if there is any setup to do on Ardupilot side or herelink settings to prevent this Telemetry Data problem to arise.

Thanks in Advance,
Bruno

1 Like

Can you confirm the version on the GCS unit and air unit?

Hello Michael,

I can confirm it better on monday, but I am using the latest stable version, this one announced at this link:

Thanks, Bruno

I have exactly this going on at the moment as well, its really curious, am on Nov 21 Beta

Customer said all was working well, Herelink battery got low so they put it on charge, and now its like Mavlink has stopped working. Have video and RC, but Solex/QGC/MP (on Herelink and Laptop with UDP) all see no telemetry.

As above, tried everything, have just reset the herelink and reinstalling it all as I type… came here to see if anyone else has seen it :slight_smile:

Can confirm the above, reseting herelink does nothing. Fix is to reflash the airunit via USB

Good morning @JacksonUAS,

Yes, in my case, I tried everything and only reflashing the airunit via USB solved my problem.

In fact I had the same trouble two months ago, but at that time when temetry data stopped arriving, I noticed that SERIAL1_BAUD was setup to 115200, then I changed to 57600 and everything returned to work fine. Since then I configure all drones to work with baud rate 57600 to avoid this kind of problem.

On this specific UAV that the problem occured this week, I also noticed that I left the baud rate for the telemetry port in 115200, tried to setup to 57600 but the problem persisted until I reflashed the Air Unit.

And the problem really seems to be something messing up with the Air Unit, because the ground unit was able to work fine when we ran a SITL simulation in our wi-fi network and accessed it via Ground Unit.

@Michael_Oborne is there any chance to have some kind of misconfiguring of air unit if the telemetry baud rate is setup to 115200 or maybe it is just a coincidence?

I have many units working at 115200 baud. Would be interesting if that needs to be changed.

A small poll about the configuration within the community:

HereLink baud rate
  • 57600
  • 115200
  • other

0 voters

please make sure you guys are on the latest air unit fw

Is, and was :slight_smile:

ok ive just made some changes to the Herelink Settings app

  1. make sure its paired, and the air unit is on
  2. goto the settings app > Airunit
  3. click Update This App
  4. open herelink settings again, goto Airunit
  5. pick the baudrate you are using. and click Reset Baud

it should now be working, if all goes to plan

1 Like

Good Morning @Michael_Oborne ,

I have just arrived at factory and all my units have these current versions installed:
Air Unit: AAU01211129
Ground Unit: BRU01210730

These are the latest stable or not? When I check for updates both from Air and Ground Units they shown to me the systems are up to date.

This procedure for updating the Herelink Settings App, the step 5 should be done whenever my Air Unit stops sending Telemetry Data without explanation?

Thanks in Advance,
Bruno Bagarini

the air unit firmware you are on should have resolved the issue, the issue was with an older firmware.

Ok Michael,

I will update the herelink settings app for all my units.

Thanks a lot!