Herelink Video Stream Issues [Solved]

Hi I had a heck of a time getting video to work after my latest firmware updates and wanted to share what worked for when when resolving the Herelink video streaming issue.

First off, I could not get any video to stream not on my GoPro 7 or HDMI out from my Raspberry PI.

GOPRO HDMI: I was able to get video working on the GoPro by manually putting it into monitor mode or unplugging it and plugging it in auto palces it in monitor mode most of the time. The issue was my Herelink settings. My GoPro does not do 1080 only 960,1440,2k and 4k. I started getting video on my GoPro once I disabled the “1080P video” option.

RASPBERRY PI HDMI OUT: I could not get this to work at all after having it work out of the box in previous firmwares. Turns out I was also using a new PI that was defaulting to a framebuffer size of 1333x???. I edited /boot/config.txt and uncommented framebuffer_width and framebuffer_height and set the values to 1920 and 1080 respectively. After I saved the file, I rebooted the Raspberry Pi and the video automatically started working in the Herelink. It worked regardless of the “1080P video” option.

I am now back in business with my Raspberry PI streaming custom thermal images processed and pushed to the framebuffer, out to the Herelink and onto my screen for turtle detection!!!

1 Like

I discovered I needed a few more settings after all for the Raspberry Pi to reliably boot with the entire flight system at the same time and get video without plugging and unplugging.

My /boot/config.txt now has the following changes:


hdmi_force_hotplug = 1
framebuffer_width = 1920
framebuffer_height = 1080
hdmi_group = 1
hdmi_mode = 16

Another config that might work:


hdmi_force_hotplug = 1
framebuffer_width = 1920
framebuffer_height = 1080
hdmi_group = 2
hdmi_mode = 82

For those who may read this topic later:

To clarify on the settings being posted. The key variables here are hdmi_group and hdmi_mode.

framebuffer_width and framebuffer_height are not necessary and I believe depricated on Buster.

For a better explanation of the hdmi_group. group 1 is for CEA (look it up) group 2 is DMT.

When choosing the mode you need to look up the linux/raspi table for each respective group. You can find it here:

I am using mode 16 which is 1080P at 60Hz.

Alvin posted a config with mode 34 which maps to 1080P at 30Hz