Herelink video streaming issues

Im running latest beta firmware and cannot get video streaming to work reliably with GoPro Hero 7 Black. There are multiple issues:

  1. Air unit HDMI inputs do work - but not too reliably - sometimes they keep looping on/off (especially when disconnecting/reconnecting camera on the fly or switching cam inputs from apps).

  2. Getting live streaming working is very unreliable. What seems to work best is keeping camera connected to hdmi input but powering it on only after air unit is fully operational.

  3. Switching cam inputs back and forth from Solex/QGroundControl app will make video stream to disappear and very hard to recover. Solex has also cam selector control flapping problem - when trying to switch back to previous camera.

  4. live stream seems to hang very often. Switching to home screen in Solex and rebooting camera seems seems to help to recover sometimes. If that does not work - rebooting everything (air unit, remote unit) helps (remember to turn on camera later than air unit).

Tested modes were 1080p/25/24 and 720p/50.
Any ideas what to check or how to debug it further? @sidbh?

Are you running the GoPro with the power timer turned off ?

The GoPro is stroppy on HDMI in my experience in general as it has to enter the output mode. It is best to turn the camera on after the air unit so it properly detects connection and enters external mode.

I have only seen dropouts when the camera goes to sleep my self and it’s had a ton of bench time last week as well, strange.

On the Solex flipping can you explain more I don’t quiet get what you mean and I’ll go check.

@MadRC reproducing problems on cam input change:

  1. lets say you have working streaming on cam1 input (and dont have camera on hdmi2)
  2. switch camera input to cam2 in Solex (as there is no cam stream wont work - not important)
  3. try to switch back to cam1 (stream wont work there anymore - but it should - as it was)
  4. Solex will show old selection (cam2) time-to-time - ie not persisting your input choice back to cam1 (thats what I called flipping). Most probably some UI bug - race between your finger input event and persistent selection setting (which havent changed yet).

@kellyschrock

Did some more tests today - and here is a video of one of the sessions - illustrating solex camera input switching problems: https://www.dropbox.com/s/7bfgo0se6t6snhh/herelink-solex-video-switching-problem-480p.mov?dl=0

Today’s tests were with better results - had also some successes on switching - still very unreliable on Solex.

I havent done extensive debugging on the matter yet - but there are some patterns emerging:

  1. It seems to be Solex related problem - as QGC cam switching seems to work.
  2. After loosing video stream due switching - restarting Herelink remote unit helps. Restarting Solex app alone does not help to recover the stream display.
  3. Herelink Air unit does not need restart to recover the stream (only remote restart required) - so it seems its maybe not related to air unit.
  4. When stream breaks in Solex - it still can work in QGC - which hints its more Solex stream receiving issue, than herelink remote issue in general.

Overall it feels like stream receiving process pipeline termination and (re)start in Solex has some reliability issues. QGC seems to lock UI cam input switcher for transition and works better.

@kellyschrock - any ideas what could be the root cause - and if stream switching can be improved in Solex? Is it a gstreamer based pipeline there?

1 Like

Hey guys, I’m running into the same issues. Same Beta firmware as @frame. I have a HDMI FPV camera from Foxeer that does just fine on both Solex and QGC, picks up every time. I also have a GoPro Hero 7 black and another cinema type camera that just will not connect to Solex no matter what I do. I can get the video in QGC but when I shut down QGC and switch to Solex, I get nothing at all - continues to search for video.

Any ideas?

Thanks!

2 Likes

first thing to try is not opening QGC at boot and just using Solex. The order I have always found most reliable is connect everything and make sure cameras are on.

Turn on GS and then open Solex. Then power up the air end.

1 Like

Hey Ian, I have tried that with no success. No matter the order I’m still facing this issue. The strange part is that some of my cameras work fine with both apps, but my GoPro and cinema camera are struggling with Solex. Would it help if I shot a video?

I deeply suspect we are actually talking about multiple issues here - and its easy to get confused between them - as they all fall under “video streaming issues” :slight_smile:

So far I would categorize them as follows:

  1. Solex cam switching issue
  2. HDMI input issues on Air Unit - camera dependant
  3. Stream processing issues (hangs, etc - not so app dependant maybe - not sure where they occur - in air unit or in remote)

On this

  1. Solex cam switching issue

Kelly is making some changes on this to prevent accidental switching to an input when their is no second camera. I’m playing more to see how this behaves but it’s been OK but not perfect.

  1. HDMI input issues on Air Unit - camera dependant

Very much camera dependant, it don’t make sense though that one camera works in QGC and not Solex, that is odd.

2 Likes

Thanks for the update Ian, as far as the issue where it is getting an image with QGC but not, Solex, I agree- it is quite odd. I will spend more time with it today and let you know if I run into anything else.

2 Likes

I have played with this a lot yesterday and seen the issues. It’s being looked at now.

3 Likes

Same here with a Sony RX0. Video streaming works in QGC but nothing in Solex.

It’s odd your getting nothing in Solex at all. The first thing is do not open QGC on boot as it will hijack the feed. If it’s running in background it will give you issues and the swiping close may not kill it. You may need to Force from the settings menu in apps.

Kelly is working on this now Hopefully we will see some improvement soon.

Along the same/similar lines, I’m having orientation issues with the GoPro7 feed coming through on the Herelink. Anyone got a way to flip the stream so that up is down and down is up? I really don’t want to have to mount my gopro7 where it’s not clean (version 1.9, 1.8 worked fine).

Nothing should have changed from orientation point of view.

There is no flip in the Herelink and it takes what fed out by HDMI. There are setting in the GoPro for this as i recall though.

I tried the settings in the GoPro, but it didn’t work. go figure.

i’ll keep trying it looks like.

Any news on this? I’m fighting with the same issues with one of my Herelink units.

  1. GoPro Hero 6 sporadic/unreliable video
  2. FLIR Vue Pro R (with HDMI converter) sporadic/unreliable video

I tried Canon M50 in QGS and works. Not in Solex: Unable to stream: receive timed out
Same with GoPro 3 Black.

I tried Solex on boot, doesnt work.
I tried with QGC, and works.

I tested HDMI1 and HMDI2. Same results in QGC and Solex.

1 Like

Are you on the latest firmware ?

2 Likes