Herelink video streaming issues

Thanks for your reply, Ian!

I updated Herelink lastest firmware last week.
If you are talking about Arducopter version, I’m working with v3.6 not v4.03.
But in GCS the video works fine with this firmware…
If it’s not necessary, I prefer to continue using v3.6

1 Like

i have standalone video test app you could try, but you need to install in developer mode

1 Like

Thanks Michael for the app.
I was wondering if after installation I would have some incompatibilities with Solex o GCS.
The app is a Mission Planner version for Herelink or only a video test?

only video test, but maybe a sample as well.

2 Likes

Thx! I’ll take a look.

Hi @Michael_Oborne, @MadRC
New issues with the Herelink… is my nightmare. After wait three months to repair and receive the Herelink by a scroll defective, I needed to update all modules. But, here is the list of issues:

  1. Solex not detect HDMI ports (tested with three cameras working on QGC)
  2. @Michael_Oborne I tested your app and all cameras works fine. THANKS!
  3. It’s impossible to arm the copter in Stabilize mode. (throttle too high)
    a. I tried enabling/disabling throttle center zero.
    b. WBus1 and WBus2
    c. Changing the mode of the sticks to mode 3 and 4.
    d. Reversing RZ channel.
    I only arm without GPS pos in alt hold.

Versions: Arducopter 4.0.3
Herelink: SRU01200616
Air Unit: AU01200226
QGC: Development herelink-v3.5.6 2020-02-11
Android 7.1.2

SOLVED SOLEX HDMI: After reinstall Air unit Firmware works.

Hey there,

I have issues with Solex and video streaming as well :frowning:

Air and Remote Unit flashed to the newest version, using a GoPro 4 Black.

If I start Solex first, then turn on the Air unit and afterwards connect the running GoPro to the Air unit nothing happens (LED1 off). After I start QGC, it takes 4 seconds and the video stream starts (LED1 Green).

However, if I go back to Solex I still have no video…

Update: After removing the touchscreen of the GoPro, LED1 turns green after starting Solex. Still, livestream is not working. I have to add that no autopilot is connected yet.

Hi guys,
I am using GoPro7 and am facing the following issues:

  1. Solex has no video feed; and
  2. QGC - video feed freezes when I try to record
    I have updated the GC as well as air unit.
    Please help.

The settings in gopro will not help. It seems the feed depends on the orientation of camera in this mode.
I have changed the mounting so that the camera is not upside down.

do you have a autopilot connected?

I too Face similar problem with herelink

On connecting gopro hero 7 with herelink,
no video in solex and video freezes when try to record in QGCS.

And i have connected with Cube_orange

So I tried changing the video settings on go pro to 1080 - 30 or 60 fps, and I directly start Solex after booting Herelink.
This seems to solve the problem of getting video on Solex and I can properly record video as well.

However on QGC the video freezes when I try to record.

Yes I am using the Cube Orange with latest Arducopter firmware.