HerePro Alpha module Moving Baseline issue

This is a continuation of thread originally posted on ardupilot forum HerePro moving baseline configuration issues - ArduRover - ArduPilot Discourse .

1 Like

Thank you very much for looking into this. I’m very curious to understand the outcome!

@zoran I have a firmware for you test. Please let me know how it goes with this version of the firmware. You will need to update through DroneCAN panel on mission planner. When asked select no to download from internet and manually update the firmware by selecting the file.

I have added HereProAlpha as a target to GitHub - CubePilot/GNSSPeriph-release project and will be included in the next v1.11 release .

Hi @sidbh,
Apologies for the late reply. I didnt receive an email notification for some reason. Thank you. I will test this firmware.

Hello @sidbh and @Yuri_Rage,
I only just had a chance to sit down and test the system based on the new HerePro firmare. Apologies for the delay.
I started from scratch (default) with v4.2.3 (stable) of the Cube firmware and configured this as i had done many times following the manual etc. With the new HerePro firmware, it worked immidiately. They even picked up some satellites inside my house but i did take it outside to see how that improved.

When i attempted to enable auto mode i had some similar unhealthy AHRS issues pop up. I re-calibrated the accelerometer and this didnt help. I also had moved the HerePro modules to their original position on the rover at a distance of 250mm apart. So i am not sure if this was the issue.

So then i decided to update to V4.4.0-beta8 and at the same time moved the HerePros further apart to 500mm. This combination worked and removed all errors.

I setup a single waypoint in my backyard and when i did activate AUTO mode, the rover went at full speed into the kids cubby house. I am not sure if it was even aiming for that single waypoint. While I consider this a success, I am now wondering if i have missed something in the configuration?

Thanks again for your help. It has literally taken months to reach this point with these Alpha units.

Hi @zoran can you share logs. That will give me more idea as to what happened.

Hi @sidbh,

Please find the link below to the log files. I believe the last 2 files (2023-10-28 20-56-22 and 2023-10-28 20-50-28) are the points that i completed the testing.

I have also included the config file for your reference. Please let me know if you have trouble accessing the link.

@zoran from your logs, the mode AUTO is never switched to because EKF is not healthy in any of the logs. Please note that for GPS and especially GPS for Yaw to work properly, you need to have a really wide clear view of the sky.
From the logs it looks like you are testing this in a heavily builtup area with a rover. You do get lock good enough for GPS to calculate Yaw, but the quality is still not good enough for EKF and in turn AHRS to be healthy.

Hi @sidbh,
Thank you for the feedback. You are correct. I am completing the testing in my backyard which has other houses nearly. I will test this in a nearby park next.

Aside from the number of satellites connected, is there any other indicator of the quality of the GPS or healthy AHRS, or if this is not flagged then I can assume it is good?

Sorry, I’m having the same problem. I have two sets of HERE Pro GPS off the shelf. I want to create a GPS effect for yaw and apply it to the drone to avoid magnetic field interference.
But I set it according to the parameters of and GPS for Yaw (aka Moving Baseline) — Copter documentation , but all have no effect.

I would like to ask, if I want to burn the firmware you provided to HERE Pro, do I need to burn Rover and Base at the same time? Or do I just need to burn that side of the rover?

The parameters I set are as follows. I would like to ask if it is a setting error.
GPS_TYPE2 = 23
EK3_enabled = 1
EK3_SRC1_yaw = 3

Because the official website does not mention the need to set the following parameters in the GPS for Yaw section: CAN_D1_PROTOCOL, CAN_D2_PROTOCOL, CAN_P1_DRIVER, CAN_P2_DRIVER, NTF_LED_TYPES

Sorry because I’m also having issues with the DUAL GPS for yaw when using the HERE PRO GPS. I would like to ask you about the process and problems of burning HERE PRO GPS firmware.

  1. The burning method can be operated according to the official website link (HerePro Manual - CubePilot), right?
  2. For the firmware part, do you burn the firmware directly from the GITHUB link ( provided in this forum?
  3. Do both BASE and ROVER GPS need to re-burn the firmware, or only one of them? Is it the BASE side or the ROVER side that is burned?

I updated my HerePro firmware as i have the Alpha release versions. Not sure if this work for you.

Latest Version:

Alpha Version:

@益德_廖 Please Confirm what hardware you are running. There are very few Alpha units out there. If you try to load HereProAlpha on non Alpha unit it will simply fail to load.

Thank you very much for your response. I’m sorry that I have been dealing with other matters these past two days and ignored your reply.

My GPS hardware is the latest version here pro, which is different from your Alpha version, I’m very sorry for the confusion.

First of all, thank you very much for your reply. My GPS hardware is the latest version here pro, not the alpha version. I’m very sorry for the confusion.

I would like to ask you about the settings or firmware burning of the latest version of Dual GPS for Yaw here pro. Can you give me some guidance?

@益德_廖 The shipped HerePro firmware should work fine. Please ensure that you have configured the setup correctly. Share your Param files from Cube and HerePros (both base and rover) as well. Also please create a new post, as this is with regards to different hardware.

Hello @sidbh,

I just managed to complete some testing of the Rover in an open field. I have attached the log and config files. It looks like the open sky did have some positive effect on the EKF error and removed the poshoriz_abs off error I was seeing in my backyard.

During my test i created a single waypoint around 10m away from the home position. I then brought the rover back near the home position and selected Mission_Start. The rover then turned around in another direction and launched full throttle with no indication of stopping. Luckily i had a rope on it to prevent it from going to far.

Can you please help me to determine what could be causing this issue? Is it the alpha units that are not working correctly?

Thanks again for your support.

Hi @sidbh,
Just did some more testing and have managed to get it working. The obvious issue was the rover speed and throttle settings. but i also discovered that i had reversed the steering to suit my very basic RC controller, so it was steering in the complete opposite direction. I fixed this and now it goes to target brilliantly.

Thanks again for your fantastic support @Yuri_Rage and @sidbh