Motor almost off in the air and high cliping

(AMV) #1

Hi!

I was trying the first flight of one of my new builded drone.

I have set some PID for the model, some manual twiching from another similar drone I have build with the same specs before.

So I was seeing the drone, 15 meter high, and I saw the motor 1 was very very slow… not stoped, just very slow. The drone doesnt lose control, but I felt on the remote the drone was less responsive.

So I tought, if the motor 1 was almost dead, the ESC or some elctronics could have some problems, and on the telemetry Log I will see a very high signal on motor 1 from the FC, and a low signal for the motor number 2.

But this is what I get, I got the opposite

So i understand from the graph the FC sent the signal to Motor1 to be that slow to that point. Em I right? So no electronics or hardware problem I think.

meanwhile I was flying, I put the tune graph from MP to check the vibrations, the Vibe window, and the EKF barrs to check the flight. The numbers were ok over all the flight.

This is the Vibe numbers.

I think its a normal chart.

BUT, the cliping of the number 2 was awful:

I understand the cliping is related with the vibrations on the first chart, or im wrong? And i think my vibrations are no to high to have that kind of cliping.

So, that cliping can be related with the motor problem? Bad PID can result in high cliping?

Here is the Log

http://robomotic.dyndns.org:16211/archivos/logs/motorIssue.bin

I did 5 flight, and 3 of them were OK, no motor problem. Here is a log from a normal flight

http://robomotic.dyndns.org:16211/archivos/logs/goodFlight.bin

I will appreciate all your comments and help!

Im using Pixhawk 2.1 BlackCube, 3.6.11FW, Here GPS

Thanks!

(Mike Boland) #2

I answered this in the Ardupilot forum.

#3

Link?

I assume without seeing your answer it went something like this…

Your vehicle is seriously out of balance, or something is wrong with the motor that is clipping.

Regarding vibration… fix issue one, and post a new log.

When posting to the forums, I understand that you may want to get the best answer possible, so you think posting to multiple forums may help.

But at least add a link to your first post in each post, so people are not spending time working on a problem that has already been solved elsewhere.

(AMV) #4

Im very sorry, I wasnt aware were the same. I will next time

#5

Can you post a link here please?

(AMV) #6

Here is it

Something I still dnt understand, how can I have cliping if the vibrations are not so high?

Thanks!

#7

So you didn’t try resetting the old flight controller? Load plane and then copter?

Clipping during extreme manoeuvre is not unusual nor is it something to be concerned about, continuing to clip through the whole flight is.

(AMV) #8

I did the default parameters on the older FC, and same result. What do you mean with load the plane and then copter fw? Why do I do that?

good to know about the extreme manoevers!

thanks!

#9

Loading plane and then copter guarantees that all parameters are gone…
start from clean… don’t then load any old parameters, just change the ones needed for flight.

1 Like
(AMV) #10

Thanks, I will try, but if a change the FC for a new one, I think the problem must be other thing.

I will change motors and ESC today.

#11

No, by changing flight controller, you changed everything, you changed the setup completely

1 Like
(AMV) #12

Exactly, so if that would be the problem, cliping were disappear, but not, still there.

#13

Not talking about the clipping. The clipping is a mechanical cause…

The imbalance in output was caused by something physical. So many potential causes.

(AMV) #14

An update

I have just try another Hexa I had almost ready, same ESC, same motors, same FC (the only difference is the one with the cliping has the blackcube it says PixHawk in the case), I uses the same props, and no cliping… very very strange

They are almost brothers…but the withe one works just fine, same tests, and the only cliping was on the landing.

So the next step will be change all the motors to check if one of them are making problems

#15

Good.

Once you change something, it doesn’t guarantee that that thing was the cause of the problem

(AMV) #16

Hi!

Some Updates.

Today I have try the drone on my benchtest, just with one prop. I have armed and TH up and move the sticks to see, hear and feel the drone. I have notice a strange sound and a vibration in some moments. So I did the same but with the Morot Test on Mission planner, and over 80% TH, this is what happend, in the next link there are 3 videos.

http://190.100.113.54:16211/archivos/Videos/motorProblem/

I have try 3 motors and is the same.

Any idea? May be a frecuency ESC problem?

Thanks!

(Hampus Berggren) #17

Interesting issue. Hmm, have you balanced all props? Could you by a reflecting small mirror on the arm reflect the dot from a laser pointer to see if the weird noise follows the reflected dot vibration?
Note were in the range the vibration peaks.
Then, if possible, move the motor and prop to another kind of shorter drone arm, piece of wood, square metall or so and see if the peak is moved.

Maybe you should tie the drone down to the table to be very safe while testing. Accidents can happen, starting wrong motor or so.

Some ESC’s feature timing change. Something to test later maybe.

1 Like
#18

First thing I would check is your ground wires… is your ground signal wire connected at the servo rail?

Is your ground power wire big enough?

1 Like
(AMV) #19

Thanks! The props are balanced, the same props are used on the “brother” drone, the one fly without cliping.

I think the laser is not need it, because I can tell you the drone its vibrate when that happend, I can feel it on the other side.

About to tie up the drone, you are right, I will.

thanks!

(AMV) #20

Hi philip

Yes, the gnd are connected to the cube.

The main cable, the one who goes from the XT90 to the power distribution hub are 10AWG, the same wire from the batteries, so that must not be a problem.