Motor almost off in the air and high cliping

An update

I have connected the signal ESC directly to the RC TH channel, to avoid use the Cube signal, and this is what I get

The motos runs just fine…

I already change the Cube and the carrier…

An Update

I have an APM FC and I did the MP Motor test with that and then with Pix BlackCube

This are the result:

Here are 2 videos, with MP motor test, 50, 60, 70, 80, 90 and 100TH in both case


PixHawk Cube2

So, with APM, no rathle…

What could be the problem with the cube?

This are miy ESC and Motors


The problem is exactly what I first was looking at, you have a ground rise issue caused by the length of your power lines to your ESCs

Mix this with ESCs that are not 3.3v compatible and you will get this issue.

This is a known limitation of many cheap ESC’s, especially those that have the ATMEGA8A processor onboard as it has a known issue with its signal levels being at 2.4v rather than the correct 1.4v for “high” TTL levels.

The “solution” is either to change your ESCs, or use 5V signalling

For 5v signalling we have two options…

  1. The green cube
  2. The orange cube

The orange has a software switch to select voltage level on the PWM lines.

The Green cube has only 5V signalling.

The recommendations for you is both fix the ESC, and change to the orange cube.

Thanks @philip, I really apreciatte your and the comunity help.

To avoid this problem again, can you tell me how to check where I can find the 3.3V compatible and about the processor? Im checking the ESC specs and I cant find that information. In fact, I thought the ESC has ARM processor, not ATMega.

In the other hand, can you recomend me a ESC for this kind of motor? 4010 340-380kv 6s, may be a very small one? BLH or OPTO?

As always, Appreciate your help and comments!


I had a look at that esc and it is 32Bit not at atmega.
But the issue is still the same…

Put a scope on and watch the signal on the pwm line.
Set the oscilloscope ground to the ESC ground, then get a trace of the issue

1 Like

ok I will, what about the ESC recomendation? :slight_smile:

I hesitate to recommend any… too many choices…

OK, new update

I have installed a new ESC and a motor over my benchtest, conected to a cube, try the motor test and TH from the remote, and no problem. I have put a very large signal and power cable to the ESC and still ok.

So I tought, ok, maybe is the ESC from the drone or the motor has problem, but before to take all the dron a part to take the motor and ESC out, I tought to connect one of the motors of the drone directly to the cube on the bench. and this is what happend.

As you can see, if I use the cube from the bench, no problem.

I already change the cube and the carrier once by the way.

The last test was installing the cube of the bench on the drone, and again, the same problem, i think must be something related with the cube power source, its a Mauch Enectronics, this is it


I already think the drone is hunted…

Now Im going to check the power source of the Cube inside the drone, its from Mauch Electronics, it suppose to be one of the best for the drones.

What do you think?

ok, here a new update.

I have realize if I start to unplug the motors from the cube, the ESC start so work better.

Here is a video with the last 2 motors.

Ite really doesnt matters wich motor I connect, at the moment to connect the second motor, the problem show up again.

Any idea?

That is super strange!!!

…its hunted, I know…

I made the same test with my “good” drone (same ESC, same FC, same cables, etc), and if I do the motor test give me the same results. That drone flew almost 4 hours las fryday, and no cliping or trouble.

Here is one of the logs of that day, almost 44min flight, @philip can you give a quick check and see if was a normal flight? I have checked and didnt found nothing strange.

May be its a Mission PLanner Motor Test problem?

By the way, I have try the Orange Cube, and the same…

I will appreciate it!


On cube Orange, did you set the output voltage to 5 v in the parameters?

nop, I dont, can you tell me what paremater is?



0 = industry wide standard 3.3v
1 = 5.5v fault tolerance

1 Like

Hi @philip, so I have try it, and you were right. 5.5V and motor test works perfect. You are awesome!

Can you tell me wich one is the most reliable Orange FW to flash it?

problem solved!

1 Like

Hi @philip

Last question to close this issue, i was cheking the The Cube Kore carrier,

…and an option of the carrier is this one:

…I saw its a switch on the carrier to change the PWM voltage.

I dont have that carrier, I have the Mini Carrier Board and airbot carrier. I was looking at to see it those have a kind of jumper to change the voltaje, and I found this:

Is that a jumper to PWM or something relates with the RC reciver voltage?


No, the jumper on the mini boards is for the RCIN pin to switch between normal RCIN (5v) and Spektrum (3.3v)

In another week or so Cube orange will be able to run the 4.0 RC code that’s about to be released! Which is really cool!

1 Like

@philip A question, can a ESC runing on 5V signal reboot the FC working on 3.3?



Hi @philip, i was cheking the blackcube specs, and I found this

8 x I/O connected PWM out (Solder option for 3.3 or 5v levels, default 3.3)

So there is a posibility to change it to 5V soldering a jumper or somethink like that?