New Cube Blue / Orange with PX4 1.12.3 on Windows 10 - Mavlink COM Driver Issue

Hello all, apologies for reposting this from here, but I felt maybe it was slightly different and deserved a better title.

I have a brand new cube orange and blue (both have the same issue) on ADS-B carrier board. I was able to flash the latest PX4 1.12.3 via QGC using the usb port on the cube itself and not the carrier board. It shows successful and plays the right tones. My issue is after the flash. No matter what I do with Windows 10, device manager still shows Cube Orange Mavlink (COM3) as “A device which does not exist was specified.” As such, QGC cannot recognize the cube so I can’t set parameters. I have uninstalled drivers, used MP to clean drivers, reinstalled and I am out of ideas. Thank you for any suggestions you can throw my way.

I would also like to add, if I flash ArduCopter then everything works as expected, no driver issues at all.

In what I would call an interesting business move, Auterion/Dronecode have recently removed PX4 support for the Cube from their standard release and have made it a cost extra option for their clients who are paying for support.
It looks to me like they are moving towards a Freemium model where if you are a hobbyist and using hobby grade hardware there are free code features and hardware support available in the standard release and if you are a commercial user or you want to use better hardware and better flight control features then those are cost extra options.
I have not tried this myself but I have read there is a workaround where you can load PX4 1.11 firmware onto a Cube Orange (i.e. the last firmware to support the Orange) and then you can load some other PX4 firmware after that. If you try that let me know if it works.

Thank you for responding, as I have been getting desperate for any information. That thread is what got me to this point. I was able to load 1.11 and then get to 1.12.3, but the driver issue has persisted across all versions. CubePilot has a documents section addressing this issue, but the steps do not resolve it. I have loaded their recommended drivers to no avail. I have seen other threads and issues in the github but the resolutions seem to be all over the place and none have worked for me on a brand new machine and cube. I have no issue paying for support, but CubePilot doesn’t seem to have any links and PX4 is says its a hardware issue.

It is only a called “hardware issue” because that is a convenient euphemism for PX4 making a business and a political choice to remove support for the Cube Orange Hardware. The only real hardware issue is that Auterion is making their own hardware so they have removed support for somebody else’s to encourage you to buy theirs.

It is not a driver issue. The standard PX4 code recognizes that it is loaded on an Orange and does not run. It is kind of pointless for CubePilot to make is own fork of PX4 that removes the code that prevents PX4 from running on the Orange when there is already another version of the Cube - the Yellow made specifically for the PX4 code. Both the Yellow and the Orange use the same drivers

the reason the resolutions are all over the place is because companies using PX4 on Cubes are using their own forks of PX4 and they have different workarounds.

You can do the same thing and compile your own PX4 code with Cube Orange and run it. Maybe running ArduPilot might get you in the air faster

1 Like

Yes, unfortunately what Craig said is correct.

This is really a bummer. I directed my company to buy this platform because we need DOD compliant parts for research. We already have several platforms running ArduCopter, but I really wanted to give PX4 a try because I feel the documentation is far better than AC’s - at least for part configuration, etc. We had significant issues getting auxiliary servos to work with AC due to how you have to chain everything through vs PX4 seems entirely simpler. In addition, QGC seems significantly easier to operate and most of the cameras / sensors that we were going to implement are for PX4 being configured in QGC.

Now I know that QGC can work with AC, but I fear we end up back in config and tuning nightmares that we had with AC. Maybe these are irrational fears, but I am feeling really bummed that all the promotional material and resellers advertise these modules as fully working with PX4 and yet to have that ripped away at last moment is a pity.

At this point, I regret recommending buying these modules and we will just have to see what comes out the other side.

Edit: The only bright side out of this whole deal, is I can connect to the cubes via RFD-900X radio and we can do the config and everything over that.

The Cubes are DOD compliant hardware and there are many companies using both ArduPilot and PX4
https://docs.cubepilot.org/user-guides/us-defence

“We are NDAA compliant, Executive Order 13981 Compliant. CubePilot PTY LTD is an Australian owned company, bringing you True Blue Allied and USA built solutions for your unmanned applications. Our Supplier, HexAero PTE LTD is also an Australian owned company based out of Singapore, our manufacturing is done by American and Allied owned Factories in California and Taiwan. “

Maybe we need to give you some help getting started

We already have multiple drones and rovers running other hardware with ArduPilot. We went this route, i.e. Cube Blue for DOD compliancy and we want to run PX4 not ArduPilot. I have PX4 1.12.3 loaded on the blue cube. It boots fine. I can connect to it via Sik radio and QGC no issue. The issue is connecting to it via USB on Windows 10, so we don’t have all of the other sensors running while we are tweaking things, tuning things. Specifically, the Mavlink COM port shows the driver is installed and correct; however, the QGC cannot connect as when you go into Device Manager, it shows that there is an error with that COM port.

image

If you flash ArduPilot to the same cube, then windows has no issue connecting over USB. We have tried multiple releases of PX4, compiled our own version based on several suggestions in Github, but nothing works to get past the driver issue. All versions of the firmware that we have flashed, boot fine on the cube and again, we can connect via USB Serial Radio, but in order to do that, we are running the platform and all the sensors where with usb, we do not.

EDIT: Hopefully my tone doesn’t sound unappreciative, because believe me I am. You are the only guys at least giving me some info, so I am extremely grateful for any advice given.

To be DOD compliant, I would strongly suggest Ardupilot, NOT PX4.

the latest round of Blue sUAS are majority Ardupilot on Cube.

To be blunt Successful companies dont use PX4

I wish I could be so much more helpful on this, but unfortunatly, since PX4 has been activly pushing against cube users, I dont really know how to help.

PX4 knows how to read our drivers, QGC can quite happily see a cube with Ardupilot, so it is not our drivers that are the issue

1 Like

Well that’s good to know. Maybe we go back to ardupilot. I will take this back to the team and see what our next steps are. Thank you all for the information.

1 Like