No GPS, Here 4 with CubePilot Orange

I am using a CubePilot Orange with a Here 4 GPS with the latest firmware and trying to receive a GPS signal through DroneCAN.
I continually get ‘GPS: No GPS’ in the mission planner after trying to change the NODE ID of the GPS. I have confirmed the GPS is getting a good signal using U-center and reverted all parameters back to as they were when it was working.
I have tried 4 different GPSes (Here 3, Here 4 and Here 4 Blue) and three different CubePilot Orange flight controllers connected to two different laptops running mission planner and in every instance, after I mess around with the NODE ID of the GPS, even after reverting it back to its original settings, I am unable to use the GPS. I have reflashed and updated the firmware on the GPS and the Flight controller and am using the latest version of mission planner.

This is the parameters that I used in ardupilot when the GPS was working (Before I’d reverted it I had changed I changed the GPS_AUTO_CONFIG: from 1 to 0 and the GPS1_CAN_OVERIDE from 0 to 20. I also changed GPS_AUTO_CONFIG and _GPS_NODEID parameters on the GPS)
14-06-2024 Parameters.param (18.4 KB)

And these are the GPS parameters (I do not have the parameters from when the GPS was working):
GPS Parameters (Bad).param (1.8 KB)

Any help would be much appreciated.

Thank you


@Finley_Redford any reason for trying to change GPS*_CAN_OVERIDE parameter. If you as mentioned mess around with NODEID of GPS the Ardupilot will record the NODEID for Here and always associate that with the same hardware, even if you reset the parameters on both. You will need to reset the Node Allocation record, to do so set CAN_D1_UC_OPTION to 1 and reboot.

In any case if all you want is for DroneCAN GPS to work. Reset all parameters on both Ardupilot and Here by setting FORMAT_VERSION 0 on both and simply follow the instructions here:

If your goal is to use static IDs set the parameter CAN_NODE on Here4. And if you want to use multiple GNSS units and choose the order of preference, set GPS*_CAN_OVERIDE parameters with nodeid. Best to use mission planner settings rather than setting parameters manually for GPS ordering, it gives better UI for this.

Hi, Thank you for your reply.
The CAN_D1_UC_OPTION didn’t work but I was eventually able to get it to work correctly by resetting all the parameters to default and then just setting up the parameters needed to talk to the GPS.


I have almost the same problem using a Here3, CubeOrange, Kore board and ArduCopter V4.5.4.

When I power the board the Here3 Leds flash blue then extinguish. Mission planner indicates there is no GPS. If I disconnect the Here3 cable to the CAN1 port and reconnect it the GPS works, no problem. I have an identical setup and it has the same problem.

I have reset all the parameters to default and reconfigured it as be below, but the problem still exists. The Here3 is connected to CAN1.








If anyone has a fix for this, I would appreciate it!

@KiwiDrones does the GPS module appear on DroneCAN/UAVCAN panel on Mission Planner? Please share your entire parameter file as well. Make sure your GPS1_CAN_OVRIDE is set to either 0 or the CAN Node ID of Here3.

Thanks for your offer to help!
Here is a link to the parameter file.

The GPS module does not appear on DroneCAN/UAVCAN panel on Mission Planner
When I power the board the Here3 LEDs flash blue then extinguish. Neither the GPS nor compass work,
If I then unplug the Here3 and reconnect it, the LEDs, GPS and Compass work but it still does not show in the DroneCAN/UAVCAN panel.
This situation has only occurred after the last few Ardupilot upgrades.
Any help appreciated.