Old Herelink stuck in update activation step


I bought a Herelink about 2 years ago from 3DXr in UK.
I recently tried to update and got an activation key (this old version does not have the key on the back of the transmitter) from 3DXr. However, the key they provided does not work, and I have tried to redo the steps many times now, while checking for all the normal faults such as timezone, wifi, etc.

We recently bought two new units, and they work like a charm, but the old unit is pretty much an unusable Android tablet at the moment. Is it possible to get a valid key that works based on the serial number I got on the unit?

Thanks in advance. Any help is greatly appreciated.


Remote information:

Any suggestions or help?

Hi ,can you please share a picture when it stucked in update activation step ?(want to know the error message or how it looks like)


First of all, thanks for helping out.

It is very similar to this post https://discuss.cubepilot.org/t/herelink-cannot-register-device-after-firmware-update/8341

I am not a the office today, so cannot take a picture to demonstrate it.

However, I also just recently got a new activation key from Michael Oborne which I will test out as soon as possible.

I think it was a thing to do with an invalid activation key I originally got from 3Dxr.