Orange blinking LEDs

#1

Just a quick question: what does it mean when the LEDs on the Here/Here2 blink orange? The blinking pattern is the same two-blink pattern as the yellow “prearm check” indicator. There’s nothing in AP_Notify about orange (or red+yellow), so I thought it might be a failure state detected by the HERE itself.

I’m asking because our last batch of units have a habit of going orange after a while, at which point they become inoperable, and we’re trying to track down the issue.

EDIT for posterity: This orange lights were actually the yellow pattern plus red LEDs which seem to appear when the supply voltage is low. This was caused by this issue, which should be solved by updating firmware once it’s released.

[Solved] Peripheral power / brownout / bootloader / PSM
#2

After some experiments, I found that after some time being powered on, the peripheral supply voltage becomes unstable. As far as I can tell, the voltage is being regulated by a current limiter that drops the voltage every time the LEDs blink. Once it is in this current-limiting mode, the peripheral supply does not reset until the pixhawk is rebooted.

The strange thing is that this problem only appears in recent batches, and we have made no hardware changes. We are drawing less than 400mA on the peripheral supply, so it shouldn’t overdraw it. Also, the Pixhawk logs do not show that an overcurrent state was detected.

I am not sure if this is related to this issue, but it sounds similar. The difference is that we are experiencing this with Cube Black, not Blue (have not tested Blue).

(It may be appropriate to move/rename this thread out of the HERE forum)

#3

How long did it take?

I plugged in a Mauch Power Module and GPS only. Its been powered on for ~15mins at this point; LEDs on my HERE2 are yellow/yellow green since power up. No change yet and definitely not orange for me.

Update: I tried again with a 915mhz Telemetry module and a cheap MAVlink LED board with 12x LEDs to add some more load. Powered for 15mins and counting. HERE2 LEDs still green/yellow - same as first power.

#4

@sidbh
@jschall

#5

Can we get a photo, wiring diagram or description of your setup? How long are your cables?

#6

I’d recommend to look on to this also, might be related. I have had same symptoms.

#7

Yep, they look related to me.

#8

Can’t get a photo right now, but it’s a simple setup so I’ll describe it:

  • Cube Black with standard carrier board. Ordered from vendor either Jan 4 or April 1.
  • Power 1 and power 2 provided by Mauch @ 5.3V
  • Servo power provided by Mauch, ~5.3V on Aux Out 6
  • HERE 2 connected to GPS 1 with stock cable in I2C mode (also tried HERE 1, both have same symptom)
  • IR-Lock Pixy connected to I2C 2, 320mm cable 30 AWG. Current draw ~150mA
  • Passive components: Telem2 connected to companion computer (no +V connected), 4 ESCs connected to Main Out 1-4, Aux Out 2 connected to gimbal (PWM out)

I’ll start taking away parts to find a minimum system that can reproduce the issue.

edit: moved to this topic.