Orange & Yellow Beta Cubes - Firmware Issues

#1

Hello all,

I have the orange and yellow beta cubes. I’m having an issue when I go to install the latest stable (V3.6.10) firmware on the cubes; it’ll give an error that says “No firmware available for this board”. I also tried the V3.6.9 when it was the latest last week and had the same error.

Is there a special version of the firmware that I need specifically for the Beta cubes? Do I need to do something more behind the scenes such that it’ll accept stock V3.6.10? Anybody else have this problem or maybe do I have bad boards?

Thanks,

Ben

2 Likes
#2

I have the same issue… OrangeCube and no firmware to upgrade, I just have an orange brick for now! :frowning:

#4

Orange and yellow will run 3.7 and above version of arducopter.
For now you can run 3.7 dev.

#5

Orange and yellow are Beta

You must run master

3.7 or later.

#6

hi!

Today I was cheking the firmware site, and now there is a CubeOrange folder

http://firmware.ardupilot.org/Copter/2019-07/2019-07-31-10:07/CubeOrange/

Lets check it!

#7

Hi Philip,

I recall seeing that the Orange and Yellow Cubes are only supported by NuttX;

Can you confirm that? If that is the case, is there any timeline to seeing ChibiOS support?

thanks

#8

Im trying to upload the 3.7 firmware and I get this error, any idea?

image

#9

The new orangecube firmware seems to work fine. I get a bad AHRS though that won’t clear.

Ben

#10

As I understand it the Orange is chibi and the yellow will run px4 if desired but chibi is good on yellow as well. I have two cubeorange running 3.7dev/chibi.

#11

the bad AHRS is because you are inside an office or something and the GPS has not ver good signal yet. Outside with a clear sky you will be good.

#12

Awesome. Thanks for the report.

#13

No, we don’t support Nuttx at all. Chibios only.

3.7 master

#14

@philip can you give me a hand with this? thanks.

#15

Try again with a more recent version, they have been playing with USB stuff in master lately.

#16

Roger that, thanks. Going to test it out soon!

#17

So here’s an update on my end: Yellow cube gives me a repeating “Initializing APM” and doesn’t recognize the GPS that is connected. Orange cube will take the firmware but will not connect now for some reason. I verified that I have the correct COM port and BAUD rate.

I checked the regular black cube on 3.6.10 just to make sure it wasn’t anything with MP and it works perfectly fine.

Ben

#18

Cube orange running the latest master as of Aug 1st, I was able to upload firmware without issues. When I go to connect to it using the USB, MP finds it as a com port even labels it correctly but never receives any heartbeat packages using any of the customary baud rates that are normally used.

1 Like
#19

There are usually 2 COM ports to a single cube. If one doesn’t work try the other.

#20

there isn’t two com ports also tried the orange cube on a regular hex carrier board that I could confirm worked with a black cube, which the black cube swapped out also worked on the mini carrier board. the orange cube is recognized in the com port as a H7 hex etc… but when connecting no matter the baud rate or carrier board will not connect. I have also tried copter and plane latest builds for the orange cube by downloading them manually and using the custom firmware install. they also wont connect in qgc so its not a GCS specific issue. might have to take this over to the ardupilot discussion as i believe its possibly a firmware issue.

#21

Looks like master is having some issues with com ports on orange and yellow at the moment.