Pixhawk Cube not booting

(Jigyasu) #1

Greetings, everyone!

Video link to the problem: https://drive.google.com/file/d/1IBkMPlyS6AKgPOzCDk4nUQf_n_hmc55k/view?usp=sharing

This is in regards to the PixHawk Cube(s) (I have 2, with the same problem) that I received in the month of May 2019 (Yes! After January 2019). The problem is that it won’t boot up. On plugging it in with a battery or via USB, the orange light at the side of the CUBE starts blinking, followed by a solid orange light.
It is not detected by QGroundControl, although it is detected by my computer (corresponding COMXX port is displayed in Device Manager).
How can this be resolved?

Thanks & Regards,

Jigyasu
Mumbai, IND

(Santosh sharma) #2

Can you try to update firmware using mission planner.

#3

Update your drivers with mission planner, and use mission planner to update the cubes.

(Jigyasu) #4

Thank you for the responses Santosh and Philip.

I was able to flash the firmware using Mission Planner. But after that, I am unable to update firmware from QGC. Also, I am not able to connect the flight controller through telemetry module. What’s up with that?

Thanks & regards
Jigyasu

(Cornel Fudulu) #5

While in Mission Planner, press Ctrl-F and select “clean drivers” from the pop-up menu.
Then download drivers from here and install them.

1 Like
#6

Most likely a driver issue

(Jigyasu) #7

Thanks everyone for the responses!

I’ll try updating the drivers then, and will update here soon.

-J

(Jigyasu) #8

Update:
So I tried what was suggested. I installed the drivers.
Still no luck with the telemetry. And I am still not able to change the firmware from QGC.

Any other suggestions please?

Thank you
-J

(Cornel Fudulu) #9

Try Mission Planner. If that won’t work, either, please post a screenshot of your top-right comport pulldown menu.

(Ryan Overton) #10

I am having the same issue with a new blue cube, and a black cube.

I have flashed to older firmware that was rover, then upgraded it to new 3.6.11… When I do this, it fixes it for a brief amount of time, but then comes back… This happens whether it is over USB or battery!

I have also tried:

  • Different carrier board
  • New SD card
  • 2 different laptops, and upgraded drivers
  • unplugging all peripheral items from carrier board to eliminate brown out on boot up

Any ideas what the issue is?

Ryan

#11

What code are you loading on it exactly?
It must be the Cube black firmware

#12

SD cards have nothing to do with firmware or anything to do with not booting…

(Jigyasu) #13

Alright. Will do that.

Thank you
-J

(Jigyasu) #14

Yeap. I tried loading Ardupilot and PX4, both for black cube.

-J

#15

On mission planner?

(Ian Freemantle) #16

I’m having the same problem with two brand new Cube blacks. Both of them won’t boot. I’ve tried re-installing Mission Planner + latest drivers with no luck. It creates a com port when connected, but then doesn’t go through the boot process. If I try to connect it just times out.

(Ian Freemantle) #17

Just checked a slightly older Cube which is working fine

(Ian Freemantle) #18

Hi Jigyasu, did you manage to solve this issue? I’m having exactly the same problem with two brand new Cube blacks

(Russell Stutzman) #19

If it is creating the com port you should be able to load/reload the firmware. You don’t need it to boot up.
You don’t want to connect in Mission Planner to load firmware. Just make sure you’ve set on the right port.
After that it should boot up.

#20

Cubes ship without any firmware. It is up to you to install the correct firmware after you investigate what is fit for your purpose