Pixhawk cube orange wont boot up

Hello to everyone. I’m having a minor issue with my cube orange; I was installing a firmware 4.1.2 copter on my board, but the cube hasn’t been able to initialise since… I removed the cube from my laptop after about 10 minutes and tried reconnecting it with no success. I cleaned the drivers from mission planner using the drivers clean option, reinstalled the mission planner, and tried everything but no luck. Could someone possibly assist me with this problem?
The Orange light from the cube wont turn off even after connected via battery.

Try re flashing the firmware, does it show up in DFU Mode in device manager ?

Try flashing rover and see what it does.

Thank you very much, @MadRC. But I’ve previously tried installing alternative firmware, such as rover and plane, but it always claims it’s already on the board. Is there anything else I could do? No, I don’t see any FDU modes in my device manager right now. I’ll share some images for your reference. Thank you so much

Ok what version of windows are you using ?

Second what connected to the cube. Is it bare on USB or in a craft.

Some times some usb will force it into bootloader even when your not telling it too.

Connect with just PMU power and let it boot and see what it does. Then connect usb.

I’m using Windows 10, and the board is presently resting on the table (it was previously on my quad). Sure, yes I tried this when the board was sitting on the aircraft , but the orange light on the board never turns off. I left it go for over 10-15 minutes, and still no output. Can you please find the google drive link you will find a video in which I have mentioned the error. Your Help and efforts are much appreciated thank you.

Can you try to load plane -> copter firmware to get a flesh reset. When it detects there are existing firmware in the Cube, the uploader don’t actually flash it again.

Thank you Alvin and Ian, but I’ve been trying to do the same thing for the past two days, I tried flashing the Copter, Plane, and even the Rover but still no luck, every time the same error occurs saying “no need to upload already on the board” I think I’m unable to explain the problem correctly, when I connect the Cube with my Laptop the orange light on the cube turns on and won’t go off and this is exactly what happens when I power up cube
Could you perhaps recommend another option for me to consider?

Copter, Plane, Rover, etc are seem as different firmware. Therefore you shouldn’t see that error message if you were loading something into the Cube.

I even attempted manually uploading the firmware by downloading and flashing it to the cube, but no success. Is there any hack or approach that I should be looking into?
Thank you very much.