PreArm: GPS1 not healthy / Compass not healthy

Hello, I have an M1200 quadcopter with Here4 and Cube Orange Plus. Flight perfromance is stable and I have done a number of flights with it. Recently, I have started to get a PreArm GPS1 not healthy and Compass not healthy message everytime I reboot the sys. SatCount shows 28 satellite connected and GPS indicates 3dgps fixed but EKF is red and I get constant Pre Arm prompts of GPS not healthy and Compass not healthy as can be seen in images. What can be the issue and how can it be resolved?

Flight log

GPS not healhty - 1

@philip @sidbh your valuable input will be highly appreciated.

Thank you.

@sidbh , @philip … Your help is reqd… We are facing the same issue in 2-3 here 4 as well…

@Alvin , @Michael_Oborne, can u suggest how to proceed… satellites are there but due to error messages, uav cud not arm… the message persists in 3-4 sys now…

Which version of firmware is your copter using?
Do you update the firmware before having the issue?
Compass not healthy: Try Accelerometer Calibration then check if it still exists.
GPS not healthy: Low baudrate might cause GPS not healthy, try make it higher.
If everything is alright, try change it to a lower version and see if the issue still exist.

Hi @Yasir_khizar

I had this issue too, with several units. I believe that CubePilot’s team will contact you here shortly.

@Mauro.Tanure , @philip How was this solved? Is there any config settings that u can suggest us? Any firmware, etc

Firmware version for cube is arducopter 4.4.4 and for here 4 it is the latest one. I upgraded it before installation on the airframe

Unfortunately, not solved by any FW or configuration. Compass hardware had issues, and the GPS not healthy was just a consequence of it.

Thanks for the response.
Actually, we upgraded the hardware of our copter sys by changing the GNSS, replacing here 3 to here 4. The idea behind replacement of here 3 to here 4 was to have better performance with industrial grade compass and dual band antennas. As prev explained that our copter flew quite a few times with here 4 and we had successful flights. The problem which we are mentioning to appeared suddenly (at random) just when we were about to fly and trying to arm the uav sys. We tried multiple iterations by changing the parameters and configuration but with no success. Then our client reported the same issue that is being repeated in 3 x sys. How is this possible that hardware issue appears in many sys while we had multiple flights with the same sys??? If this happens at random, then is it possible that problem might appear in the middle of flight?
Unfortunately, despite of tagging the Cubepilot team no of times, none of the member has yet contacted or replied to us. Hope @philip @Alvin go thru this blog and suggest the soln…

Cobra has responded, he is also Cubepilot staff.

There will be a notice on this matter shortly