Purple Cube internal compass

Hello,

 I know this topic was covered at one point, but I have not seen any thing new on it. I am building a Rover setup for a boat and would like to use one internal compass on my purple cube. I don't think its enabled or seen at all. I cant do a compass calibration. Is there a fix to enable this compass in the purple, thank you.

In MissionPlanner can you see the compass listed?
(this is not a cube shown here)

Actually if you update to latest ardupilot and then update the bootloader there should definitely be a compass - it’s no longer disabled in the HWDEF file.

Shawn thanks for the reply. I’m a noob , I dont see that compass priority window when im in Setup/Mandatory Hardware/ Compass. I have the newest arduRover 4.0 should i try the newest Arducoptor or ardupilot and then the bootloader?

I don’t have a cube purple to try that out on, but yes no harm in loading arducopter or arduplane and see if the compass appears. You can do the bootloader update too.
Usually with rover most people find they are unable to use the internal compass at all and rely on a compass in the external GPS housing anyway - to get it far enough away from all the power wiring and magnetic fields.

Purple Cube don’t have any internal compass
Check:

Alvin, I think they do have it. Its not enabled.

shawn, I uploaded the newest arducoptor 4.0.7 and new bootloader it lists no compass at all. A member in this link seemed to add it manually , I’m not sure of the procedure.

also note that the compass priority screen does not show in Rover 4.0, but does in Arducoptor.

I also checked the docs like Alvin linked to. The Cube Purple includes a MPU9250 that has a compass. I believe the hardware definition file (HWDEF) used to disable the compass for some reason, but was recently changed to un-disable the compass. That was why I said to do the firmware and bootloader update.
But there is an open issue:

that links to:

and I’m confused now. Seems like the compass was going to be enabled, but wasn’t.

Probably best to get an external compass module or GPS that includes a compass (most do)

Mallikarjun seemed to fgure it out, I’m just not a programmer like him. I believe I am to add something to the HW ID but where? Compass_DEV_ID ? What to write?

Then i think it shows up in the Compass Priority screen or He added something to that

I have a trimble GPS already im bringing in , do they make external compass modules for the Cubes? Ill look again , thanks for the help

MPU9250 does have an internal compass located on FMU board in hardware. However, it has been disabled in software since Black Cubes due to interference problem. You don’t want to use a compass surrounded by lots of electromagnetic sources…

Purple Cube is basically a light version of Black, that’s why the FMU compass is kept disabled

Edit: clarify internal compass location

Alvin

Sorry but that’s Wrong , I have had many back cubes all internal compasses worked fine.

Also orange cube internal compass worked fine

My words may be misleading. I was talking about the internal of the internal.

The black and orange have their internal compass(es) in IMU board. They also have a hidden compass inside FMU board but disabled due to the reason I mentioned.

For purple, it’s basically a standalone FMU board from standard Cubes. So it don’t have any usable in-cube compass

Thank you for clearing that up. I wont use the purple in the future. I need one compass that it.