QGround Control issue after update

After updating to version AAU01211129 on the air unit and updating the ground unit QGround always displays the message “Waiting For Vehicle Connection” and will not connect to the UAV. When I look at Herelink settings it shows that the air and ground units are connected and that there is an active link between the two. Any ideas on how to get QGround to work again?

would you please keep me updated on your progress

Will do. No progress yet though.

Don’t you have Mission planner and QGroundControl launch at the same time ?

You may try different GCS apps on Herelink. Like q7 said, maybe you have another App occupying the telemetry.

Go to Settings > App and force stop the not using ones.


Same issue. Tried rolling back, reset everything. I’ve made sure only QGC is running.

My suggestion would be to reflash the air unit to the default firmware from your computer command prompt. Then pair the handheld to the air unit. Once that is done then update the air unit software from the handheld and that should work and keep vehicle connection using QGC. I had problems after 5-7 flights of losing vehicle connection like you and then the new firmware came out for the air until by updating from the handheld and never had a problem since.

Thanks David, that is the route that I took rolling back. Still no luck.

More or less yes. Using mission planner I can verify that the Herelink hand unit and the UAV are communicating but QGC wont recognize that.

Any luck getting it to work?

Have you tried the solution posted below by Alvin? If it works would you please let me know? I will be out of town for a while.

Here’s my full saga-

  1. Purchased a vehicle from Foxtech. Herelink worked fine.
  2. Returned vehicle for service on the camera.
  3. Foxtech bound a different ground unit to the Herelink during servicing.
  4. When the vehicle was returned to me, the Herelink was not bound or connected.
  5. Paired ground and air unit.
  6. Received "Waiting for Vehicle Connection in QGC.
  7. Attempted to connect in Solex- no connection.
  8. Flashed air unit via Windows.
  9. Received "Waiting for Vehicle Connection in QGC.
  10. Updated App, OTA, and Air Unit via Herelink settings.
  11. Received "Waiting for Vehicle Connection in QGC.
  12. Updated ground unit to beta
  13. Received "Waiting for Vehicle Connection in QGC, also attempted connection in Solex and Mission Planner.
  14. Factory data reset ground unit.
  15. Flashed air unit via Windows.
  16. Paired.
  17. Received "Waiting for Vehicle Connection in QGC. Noted that Video stream was working.
  18. Restart ground unit, attempted connection in Solex.
  19. Restart ground unit, force close Solex, Mission Planner.
  20. Received "Waiting for Vehicle Connection in QGC.

Any progress on your end?

Solved thanks to @Alvin and his reply to this post.

@Alvin Any thoughts on my connection saga?

If the Herelink was working before sending to Foxtech, you may ask them if they had done any modification on your air unit.

I saw you flashed the air unit with flasher for a few times. Maybe you can try flashing the controller as well, so that to make sure they start from the same version.

Also check your uart cable.

Thanks, just flashed controller also, still no luck.

Did you try to force stop other apps as Alvin mentioned above?

Yes, that was step 19.

At step 18, did Solex work?