Second defective Herelink 1.1 TX?

I must be unlucky. Sent my first Herelink handset back for an RMA and just received the new one. Second Herelink will freeze up after about a minute of so once connected. The previous TX would simply shut down, but this first just freezes the screen. But the controls are still active such as the buttons, just a frozen screen After a few more minutes pass the unit will completely shut down. Tried flashing with the latest flasher_win (a note about that, both these 1.1 handset won’t start in fast boot mode. No fast boot displayed on the screen. Though after pressing the power and D buttons, it will update but initially flasher says the connection was refused.) After that the handset wants to update the firmware OTA. No change, still freezes. Updated the airunit OTA and flasher_win with the same results. Tried another 1.1 air unit with the same result. My older 1.0 handset has no issues working with these airunits. Are the 1.1 handsets defective of am I just super unlucky? (1.1 MB)

Just thought I should check if this happens to QGC as well. And it does lol. Seems to happen when tuning on the hotspot. Usually it doesn’t come on by tapping the hotspot button and when you open its preferences you’ll find an error message. Tap it a few times and it turns on, but then the system freezes.

Hi @philip @Michael_Oborne @Alvin ,
I am also facing the exact same issue. My herelink is also brand new.

I tried updating everything including the ground unit, air unit, and Solex.
My herelink just hangs randomly on Solex’s screen. No warning no nothing. Just hangs randomly out of the blue. It has happened 5 times till now! All hangs happen within 1-2 minutes of starting Solex, and there is nothing that responds on screen. The only option is to press the power button for it to turn off.

I also have the same airunit and GCS versions as @srbell has mentioned!
I don’t think this is what’s expected from a so-called “Quality industry-leading” product.
And there’s no fastboot screen also as @srbell has mentioned.

Please look into this issue as it is really frustrating.

1 Like

Does anyone have a 1.1V unit that enters fast boot mode normally? Seems Harkhka has the same strange behavior when trying to enter fast book. Wonder if it could be related to the freezing. My previous controller did the exact same thing.

Continuous testing lol. So it would seem if you don’t swipe down to access the hotspot function, the unit doesn’t freeze. With brings me to the second problem, the hotspot always dies. It will say error. Sometimes it will come on, but at that point the unit freezes. So as long as you stay within your app (Solex or GGC) and don’t access any system apps you’re good. Who needs wifi or hotspots lol?

Hi @srbell

Yes, you are spot on! Even I did some more testing with my unit and found the exact same behavior which you described.
As long as I am within the Solex, it works fine. I am able to move around the map with no issues at all.
But the moment I try to use any Android interface like swiping down the menu screen, pressing the touchscreen back button of Android, or even pressing the touchscreen square button to “show background apps”, it just hangs straight away!
Looks like a more serious issue now as if it happens while flying in stabilize, then a lot of damage could be done!

I hope @Michael_Oborne @philip @Alvin finds some time to look into this as it’s a pretty serious issue.

Hi all,

We have two herelink 1.1 units displaying the same issue ! Screen freezes and shows black at random times. At first happened 1-2 times per hour and now its constant. I can’t even open an application.

Complete disappointment coming from a company like yours @philip . I have been in the industry for over 15 years and its the first time we’re having so many issues with a single product. And with practically non existent after-sale support.

FYI we have missed two major deadlines and a client due to constant issues with your QC.

And here’s a video as well: Herelink v1.1 defective - YouTube

Looks like a dislodged screen connection.

Contact your reseller and send it in to them for repair.

RCinnovations said the process is I send it to them, then they send it to you and then they send me a new unit. Estimated over a month later. Is that how it’s supposed to work?

EDIT: It also seems like the lower left part of the screen is heating up abnormally much (60c+) after a couple of minutes.

That all depends on what is wrong. If it’s easy to fix, maybe a week, if it’s more serious, we may authorise a replacement.

Hi @philip

As you suggested on Facebook, I have opened a discussion on this page only for my issue which also has the link to the video proof of the issue.

Please kindly have a look at it here: Herelink v1.1 Screen Freeze Issue