SRx for telemetry port 4 and 5

#1

Hi I am trying tu use telemetry port 4 or 5 for alexmoss connection but I don’t have SR4 and SR5 parameters for this telemetry ports. There is no such parameters in mission planner or other software :frowning: I can configure parameters with SRx setting for telemetry ports from 1-3. Any idea why. I have firmware 3.5.7.

#2

SRx corresponds to MAVLink Connection instance. Only 4 MAVLink connections are supported simultaneously. You will have to set SERIALx_PROTOCOL to be mavlink and it will be attached to SRx params based on its sequence in SERIALx assignments. so SERIAL0->SR0(USB-CDC) SERIAL1 -> SR1 SERIAL2->SR2 SERIAL3->GPS SERIAL4->SR3 (if SERIALL4_PROTOCOL is set to MAVLINK or MAVLINK2)

1 Like
#3

Thanks for answer now everything is clear… so there is no sr 4 and sr 5 parameters. They are only for mavlink not for all serial connections.

#4

yes

#5

Dear sidbh maybe you have idea why my telemetry SiK doesn’t work on GPS2 port:

I would like to connect my SiK telemetry to GPS2 port on CUBE black (Pixhwak2.1). On telemetry port 1 I have mavlinktohott, on telemetry 2 I have alexmoss mavlink, on GPS1 I have here GPS and on GPS2 I would like to have Sik telemetry. It’s working on Telemetry 1 port without any problems but when I am switching cable to GPS2 conection it doesn’t work. I set “Protocol 4” parameter to mavlink 1 (tried also mavlink 2). I also tried to change parameters of sr3 to the same like good connection on telemetry 1 but that didn’t help. Anyone have telemetry connected by GPS2 port on CUBE ?
https://discuss.cubepilot.org/t/no-mavlink-on-gps2-port-on-cube/164