Strange flip incident on arducopter 3.6.11

We have a strange problem. The error appeared on drone, which normally flies well.
Right after arming in loiter mode, without rising throttle, the drone flipped backwards as you can see in log 13-16-41. (RC1_IN is at minimum, desroll changes quickly and RCOUT obviously is flipping drone )
2020-01-17 13-16-41.bin (167.5 KB)

After the incident we removed the props, restarted drone and tried to arm again, but this time it didnt tried to flip. Log here
2020-01-17 13-45-05.bin (260.7 KB)
Can somebody explain me what happened after first arming?
Can it be caused by low outside temperature (arround 0°C) ?

What RC are you using. A receiver/transmitter channel glitch has been occurring with my Taranis lately. Twice with yaw, once with loiter channel (can’t remember which channel), and once with pitch. Can be clearly seen in the telemetry if this is the case.

It is a special system that is controlled by external microprocessor generating ppm signal. There are occasionally minor glitches but they are in logs if they occur. Even if this was caused by glitch, it wouldn’t really explain what happened. In loiter mode with throtle at minimum it shouldn’t try to flip the drone.

Today I updated the drone to 4.0.0. I hope it will solve the problem. Next tests are scheduled for tommorow. If meanwhile someone is able to solve this mystery, please do :slight_smile:

Well i dont know if it solved the problem, because now i am having a new problem.

Bad GPS Health is nothing to worry too much about. I have several multicopters flying, and I don’t think there’s any that won’t throw the odd Health message randomly. There’s one that throws it at least three times per flight, sometimes more.
I haven’t seen this behaviour affecting EKF at all, or impacting flight in any way.