System Update app crashes after firmware update

#System Update app crashes after firmware update

I have purchased herelink product last week. I have updated firmware using flasher_linux utility on Ubuntu 16.04.
Console output:

Looking for Device
Found Unit Type: remoteunit

Downloading required package…
Latest remoteunit release: FRU01200409
Downloading Latest Release from
remoteunit-FRU01200409.tar.gz: 100%|████████▉| 491M/491M [03:55<00:00, 2.19MB/s]
Successfully download package
Extracting package…
100%|███████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████| 19/19 [00:06<00:00, 2.96it/s]
Successfully extracted package
Flashing Unit…
Flashing partition: 100%|███████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████| 209/209 [00:00<00:00, 758kB/s]
Flashing oem: 100%|████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████| 8.94M/8.94M [00:00<00:00, 49.9MB/s]
Flashing boot: 100%|███████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████| 23.6M/23.6M [00:00<00:00, 46.2MB/s]
Splitting Sparse Partition system.img @ /tmp/tmpym_ni_az
Flashing system 1/19: 100%|████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████| 55.0M/55.0M [00:01<00:00, 45.2MB/s]

Flashing system 19/19: 100%|███████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████| 13.5M/13.5M [00:00<00:00, 48.2MB/s]
Flashing userdata: 100%|███████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████| 10.5M/10.5M [00:00<00:00, 49.4MB/s]
Flashing recovery: 100%|███████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████| 27.5M/27.5M [00:00<00:00, 45.8MB/s]
Flashing cache: 100%|██████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████| 6.10M/6.10M [00:00<00:00, 52.8MB/s]
Flashing misc: 100%|███████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████| 8.00k/8.00k [00:00<00:00, 17.2MB/s]
Flashing firstboot: 100%|█████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████| 292k/292k [00:00<00:00, 589MB/s]
Flashing trustzone: 100%|████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████| 428k/428k [00:00<00:00, 1.00GB/s]
Flashing secondboot: 100%|███████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████| 786k/786k [00:00<00:00, 1.66GB/s]
Successfully flashed image
-------------------------------------------------------------- output ends

After the firmware update, i tried to activate the device but system update app on the remote unit keeps crashing.

Current version is FRU01200409 as displayed on remote unit.
I have connected the remote unit to 5GHz wifi active internet connection.
I have seletec US option while activating the device.
Please help.

what is ip range on wifi you connecting too?

I am using WIFI hotspot of my android phone at 5GHz frequency. Let me figure out tht IP range of the android hotspot.

Ip range of wifi hotspot of android phone is to

I have also tried wifi connection from wifi router of my office, it has ip range of to
System update app is crashing on both the networks.

ok, can you try load factory image again, and see if that resolves it

Settings --> Backup & Reset --> Factory data reset --> clicked RESET PHONE

  1. System Updates app keep crashing. Same behavior on both hotspot and wifi router networks
  2. Once I also got message “couldn’t register device” before app started crashing.
  3. I have also reflashed the firmware using flasher_linux utility and repeated the same steps. I have used sudo command with flasher utility as it was not able to get usb permission without the sudo command.

if you disable wifi does it still crash?

also try turn on aircraft mode, then turn only wifi back on


  1. Turned airplane mode on, turned on wifi (airplane mode still on)
    System app keep crashing again and again with popup message of “close app” and “open app again”
    When I turned off the wifi, app crashing stopped.

Do I have to create a tethered usb internet connection to get internet on the herelink remote device for registering and system update?

Im currently experiencing this exact problem. The system update app keeps crashing no matter what i do.

The app crashing also stopped for me when i turned off the wifi.

Can you provide a log of what’s happening

The process is on the Wiki


I am working on how to take logs from the herelink remote unit. Will be uploading logs soon.

I experienced the same issue - at some point I managed to continue - not sure what helped (rebooted unit multiple times, etc).

Well i managed to update mine. For some reason, the WiFi causes system update to crash if its not perfectly happy with the IP range and also the channel that the wifi signal is being broadcast on so i limited my Router to a max of 5 IPs which forced the herelink to get an IP if ( Once that was solved it started telling me that it couldn’t check for updates. I made sure that the time was correct but i neglected to check the date as well so i fixed that and it went through. i hope my scenario can help you as well.


Glad you got it sorted.

I got my herelink remote unit updated yesterday. I didnt change anything and used the same router. I have one more unit of herelink product, it also got updated after one crash on system update app on the same router and same development ubuntu machine.

1 Like