Ublox params go to default after power cycle


I am using a “Here 2” GPS with “Cube Black” and “Arducopter 4.0.5”.
Due to some GPS glitches that I have experienced in my area, I am trying to adjust the UBlox UBX-CFG-NAVX5 Min SVs parameter from the default (3) to a higher number.

I am using U-Center 20.10, connecting to the here2 via CAN/ UART using the mission planner interface per the Here 2 manual (tried both, using the pixhawk as passthrough).
The U-Center<-> Ublox connection is good, and I can view and edit the parameters.
After changing the required param, I write the UBX-CFG-CFG message (with all of the Devices selected (BBR, Flash, I2C EEPROM, SPI FLASH).

Uppon reloading the params, I can see the change has been made. But after power cycle to the Here, the params go back to default.

I tried using the passthrough values of 0/1/2 but this did not help. Also tried modifying the pixhawk params regarding Ublox configuration (disabed GPS_SAVE_CFG, GPS_AUTO_CONFIG).

To my best understanding, the M8N includes internal flash that allows saving of parameters between power cycles.
I couldn’t find anything on this matter on the forum/manual.

Any assistance on this matter would be kindly appreciated!


Can you try to connect your Here2 to ublox under a 3D fix environment? Just to verify the connection is good.
If yes, you should be able to see a lot of things in u-center including satellites, longitude, etc.