Update GCS Unit with Windows fails

I have tried to update the GCS unit as described in the instructions with a Windows 64Bit.
The update process failed on system 3. After that, the GCS unit can no longer be switched on and shows a black screen (Pixelcaos) directly after the logo.
I reported this problem to my dealer who referred me to this forum.
Thanks for the help.


Is it still possible to enter fastboot mode for the unit? If so, try to reflash the unit again.

Thank you Alvin for your answer. I can enter the fastboot mode, but i can’t flash the Unit. I have the same problem again and again.

Did any error message show up in the console?


Attached is the console message. I hope it helps you. Thank you very much.

Is it always stopping at step 3/19 or different each time you try?

Yes, it stopping always at step 3

Hm. Have you powered the Air Unit externally (not only via USB)?And maybe checked with another USB cable?

It is not about the update process of the Air Unit but of the Ground Control Unit. Several USB cables have already been checked.

Ok. Sorry. Did not read it properly.

Are you able to turn it off? Or does it keeps staying in the black screen (not turned off) or repeating reboot itself?

Es lässt sich nicht ausschalten, der black screen (nicht ausgeschaltet) bleibt.
Durch ein langes betätigen vom Power Button kann ein Neustart erzwungen werden.
Drückt man in dieser kurzen Zeit auf Power und D kann man in den Fastboot Mode kommen. Im Fastboot kann man nach einer gewissen Zeit durch langes betätigen von Power das Gerät ausschalten.

It cannot be turned off, the black screen (not turned off) remains.
A reboot can be forced by pressing the power button for a long time.
If you press Power and D during this short time, you can enter Fastboot mode. In Fastboot mode, the device can be switched off after a certain time by pressing Power for a long time.

Normally if you can enter fastboot, the flasher should be able to fix it.
Can you try different USB cable or PC?

I have tried with a laptop and a desktop PC. I have exchanged the cables, also no success.

Can you see if there is any files/folder with FRU prefix in the same directory of flasher.exe?
It should be automatically downloaded when you run the flasher.

Get your controller into fastboot and try to run the flash_all.bat from the file/folder mentioned above.

Can you give me detailed instructions for this please? Unfortunately, I do not know exactly what to do after your last message.
Thank you very much.

I have found the file. However, this can not be executed.

Does it show any error message?

The next picture show the error message