Where is my HERE3? UAVCAN

Hi All,

Just got my Here3 and installed.
29-Mar-22 10:36:08 : CubeOrange 001E0024 34385115 31373439
29-Mar-22 10:36:08 : ChibiOS: 45395b6a
29-Mar-22 10:36:08 : ArduCopter V4.1.5 (1002fd6e)
29-Mar-22 10:36:08 : Frame: QUAD/X
Latest MP version (no updates availeble)

Changed the params as described in the manual.
In Mandatory Hardware -> Compass I can see it and moved to first pos.
I’m going to look for the FW version and go to UAVCAN -> SLCan Mode Can1 and I see nothing (empty rows. Same for SLCan Mode Can2.

Any hint would be appreciated.


I wish I could be of help more. Really read how to use the SLCAN with a CubeOrange. To me it wasnt as straight forward as it appeared. I finally get my compass identified as UAVCAN and all updates on the screen however “missing” is checked and I cant figure out why. I am running Rover 4.1.5 and 1.377

So, spend whole day with Cube Orange and HERE 3 without luck!
But …, with a Cube Black I was able to connect but … not able to do the connection to u-center


After you entered SLCAN from mavlink COM port, go to front page of Mission Planner. Then switch back to DroneCAN/UAVCAN screen. Change the COM port to the CAN COM port. Then click SLCAN again.

Try if this give the connection.

Thanx Alvin,

I’ve tried many times multiple options but unfortunately same result.

Does the GPS work?
Also, you may try to change the node id to any value other than default.

Yes, I have position and heading in the HUD and connected to the Cube Black I have the connection in UAVCAN but not the passThrough as you can see in my earlier post

Will have a look at the node ID

Thanks for that , fixed my isue not seeing the gps .

Would be great to update the docs with that step !
Best wishes!