Windows driver for Cube Orange

Hi

Need a bit of help, I am having trouble connecting my Cube Orange to MP 1.3.7 on my windows 7 PC.
I had no issue connecting with Cube Black.
Where can I down load the driver for Cube Orange for windows 7?

sorry,
forgot to mention that I tried installing the driver from the direct link below also.
http://firmware.ardupilot.org/Tools/MissionPlanner/driver.msi

@NadMan I wouldn’t recommend Windows 7. Do you have a Windows 10 machine available?

Windows 7 is very problematic on this. It can be done but not always working. I will post something to try now

I have written an overview for this on a pull request for the docs section on Cube driver and install issues. The drivers are below for you

Cube Orange & Yellow - Windows 7

There are known issues installing the Cube Orange and Cube Yellow with Windows 7. Its advised you use Windowns 10 or later however Windows 7 can be made to work in some circumstances by manually deleting the driver files and installing the latest driver file and forcing Windows to install the correct driver manually.

  1. Delete ProfiCNC CUBE H7/F7 from device manager while the Cube is still connected, then disconnect the Cube from USB.
  2. Uninstall and reinstall the latest Cube drivers as linked here

http://firmware.ardupilot.org/Tools/MissionPlanner/driver.msi

  1. Reconnect the Cube Orange/Yellow and two devices will show up in “Other Devices” called CubeOrange-BL.
  2. The top entry will change to CubeOrange and you should see the message from windows notifying you that it is installing device drivers.
  3. CubeOrange-BL will move to the Ports section and be named Cube Orange Mavlink (COMx)
  4. If the “CubeOrange-BL” in Other Devices" does not move to Ports after a few moments, right click, go into properties, click on the driver button and wait, it should then move to Ports and is named Cube Orange SLCAN (COMx).

Your ports must look like this

2 Likes

Hi Ian,

Thank you so much for your reply.
I followed your instruction and Cube Orange is connecting with no issue now.
I just like to mention that step ‘1’ is to be done exactly as you have it, otherwise it will not work.

1 Like

Sorry my Bad had to many pages open on the CubePilot replyed to wrong one :face_with_hand_over_mouth:

Please keep on topic… feel free to start a new one

Hey there, I have been facing similar issues connecting the cube orange. When I install the drivers, the com port says “USB serial drive(com x)” instead of the slcan and mavlink ports. I have tried uninstalling and reinstalling both the Mission planner as well as the drivers, but face the same problem every time. Even tried this on another windows 10 pc and a windows 7 pc.

Any suggestions that I can follow?