GoPro 7 Black no video stream to Herelink when recording in 4K

Problem: I need to record in 4K but also be able to see the video feed from my camera so I can aim it.

Setup:

  • Custom quad rotor with Drotek Pixhawk Pro running latest Ardupilot firmware
  • Herelink HX4-06075
  • GroPro 7 Black connected to Herelink via micro HDMI cable
  • Tarot T-3D metal gimbal

Troubleshooting:

  • I did a bench test with my Atmos Ninja Flame connected to the camera’s micro HDMI port and confirmed that when the GoPro 7 Black is not recording it streams in 1080p. When you record in 4K it downgrades the video stream to 720p.
  • When I connect the camera to the Herelink using the QGroundControl app and the GoPro is not recording I am able to see a video stream (with about a 2-second latency - which is on the camera’s end and is completely fine for my application). However, when I press record the video drops out. It displays a black screen (not a “searching for video” screen).
  • I tried going into the Stream settings and disabling the 1080p but that didn’t resolve the problem.

I’ve seen other topics related to this such as: No image HereLink HDMI 720p (WIRIS PRO) and Herelink - Groundside crash and reboot with Gopro Hero 7 black but they don’t seem to be recording in 4K.

Again, I don’t believe this is a camera issue (copyright protection, etc.) because as I said, I confirmed that the camera is outputting to 720p when it is simultaneously recording in 4K and when it is connected to the Herelink it streams just fine in 1080p (when the GoPro is not recording).

Any help would be greatly appreciated!

Herelink can only support 1080P as standard. There is a separate firmware to enable 720p however it can not switch between them if it changes.

Basically you need your camera to output either 1080p or 720 continually then choose the firmware.

Hey Ian!

Thanks for the info! Where do I find the 720p firmware? Although this isn’t ideal I think I can make this work.

Check this thread and Michael’s post.

Will do! I’ll update this link if/when I’m able to get it to work.

Thanks for all that you do!