Here 2 GPS UAVCAN Advantages Over I2C Connection Through GPS1

(Muhammad Hamed Abdelraziq) #1

Hello everyone,

Since I am new here and I am currently building a Hexacopter Drone, I need someone to answer the following questions for me.

1- Which Here 2 GPS setup is more accurate, CAN or I2C?
2- As soon as I got my new Here 2 GPS, I turned the switch to I2C and connected it to my Pixhawk 2.1 through GPS 1 port. I took it outside and noticed on my mission planner window that the drone was moving randomly and it wasn’t stationary. The location was correct but it was moving. Why is that?
3- I didn’t set any parameters on Mission Planner after connecting Here 2 to GPS 1, is that okay? if not, what parameters do I need to set?

I will be looking forward to your answers based on your experiences.

Many thanks to you all!
MA

(Ian ) #2

Accuracy is no difference no matter if it’s CAN or Serial. CAN is the way forward because if frees up Valuable UART ports.

As for why the movement remember all GPS has a tolerance. If you were seeing small movement it’s either the normal GPS tolerance or your lock is not good and it’s trying to get accurate position.

Make sure it’s got clear sky and no large buildings around or any metal as the compass can affect the movement too and you can get rotation as it’s trying to get good position data.

There is very little config needed for normal GPS setup other than just connecting and then setting the compass correctly

1 Like
#3

CAN is the future, it’s time to switch :slight_smile:

Can deals with electrical interference much better than i2c

2 Likes
(Muhammad Hamed Abdelraziq) #4

So what if I want to use a safety switch, I read CAN doesn’t support that. Do I have to connect a different safety switch to GPS 1?

(Mallikarjun SE) #5

You can hard wire the switch pins on here2 to cubepilot switch pinout.

1 Like
#6

Please don’t use the safety switch!

To call it a safety switch in the first place was not smart.

The idea of putting your hand over a bunch of spinning blades to “make it safe” is stupid.

2 Likes
(Muhammad Hamed Abdelraziq) #7

@philip, you make a really good point :D! I will take your advice!

1 Like
(Muhammad Hamed Abdelraziq) #8

@philip, So I took your advice and started setting up the UAVCAN connection according to this link: https://docs.cubepilot.org/user-guides/here-2/updating-here-2-firmware

I am running the latest version of Mission Planner (v1.3.68) and ArduCopter V3.6.11.

1- After setting up the required parameters, the LEDs started to flash yellow but the message ‘’ No GPS" is still displayed on Mission Planner whenever I connect.

2- I am also stuck at step 9 (Step 9: Using the Mission Planner SLCAN interface). Whenever I click on SLCan Mode CAN1, it doesn’t show the Here 2 at all and the button remains greyed out.

I hope you can help me figure this out!

Thank you!
MA

#9

You are connected to the port in this picture?

image

(Ian ) #10

You need to change the GPS to use CAN.
I did a video on this on YT, but the prams are

You need to set the
CAN_P1_DRIVER to 1

be warned that early carrier boards have the CAN ports labels the wrong way around so for this you need to be in the Middle CAN port on the carrier, may be label CAN2 but it’s the middle port along the bottom.

Next you need to tell Ardu to use CAN for the GPS and to do this set

GPS_TYPE to 9

Finally you need to set the LED settings to use CAN as well as this is

NTF_LED_TYPES enable UAVCAN

Once this is done save prams and reboot, you shoud then get GPS working on CAN, note that when I swing UAVCAN you will not have HDOP reading as it’s no longer used, you should still get GPS showing 3D Lock though.

Also note the “safety” switch Will not work and you will either need to bypass this in the arming checks or use external one.

1 Like
(Muhammad Hamed Abdelraziq) #11

@MadRC I followed those instructions but still had no GPS… I will try again tomorrow and let you know what happens.
@philip Yes, I connected the GPS to the mislabeled CAN 2 port on the Pixhawk… no luck though.

(Ian ) #12

Just to confirm do the status led work ?

How are you confirming GPS as HDOP won’t show with CAN.

And again to confirm the switch inside has been set to CAN.

1 Like
(Muhammad Hamed Abdelraziq) #13

@MadRC @philip, gentlemen, I carefully followed the instructions and still got no GPS. The GPS LED is flashing yellow.

I changed the following parameters according to the Wiki page:
CAN_P1_DRIVER = 1
GPS_TYPE = 9
then I restarted mission planner and rebooted Pixhawk, then I changed the following parameter:
NTF_LED_TYPES = 231

The GPS then started to flash yellow but no GPS is shown on mission planner. I took it outside in the open but nothing happened.

What do you guys think is the problem here?

#14

does it show NO GPS, or no FIX?
is the Mag showing up?

(Muhammad Hamed Abdelraziq) #15

It’s showing NO GPS.

and no, Mag isn’t showing up.

#16

Can you take some photos of your setup? Have you updated the firmware?

(Muhammad Hamed Abdelraziq) #17

@philip Okay, here’s all I’ve got… If you cannot figure it out off the top of your head then I think I will just use the GPS1 port since I am not particularly picky about which setup to use. Additionally, I want to use my old Here GPS in conjunction with the Here 2 GPS for redundancy by connecting it to GPS2… is that possible? will that improve GPS functionality overall for my drone? (It’s called GPS blending I believe)

Let me know your thoughts…

Thank you very much!

gps5

#18

There are a few things that I haven’t managed to get answered here, sorry if it sounds like I am repeating myself

  1. Have you updated the firmware on the Here2 via CAN?
  2. Have you taken it outside and tried to get a lock?
    is your switch set to CAN on the Here2?
#19

GPS Blending works really well.

(Muhammad Hamed Abdelraziq) #20

I have not updated the firmware. I tried doing this as explained in the Wiki but whenever I click on SLCan Mode CAN1, it doesn’t show the Here 2 at all and the button remains greyed out. So I cannot flash the firmware to the GPS. (It might be the firmware which causing this…)

Yes, I took it outside and moved away from building as much as I could and still had “No GPS”.