HERE 2 no fix, no gps

#1

When plugged in I2C and CAN1/2; GSPS_TYPE and CAN_D1 all parameters set to 9 and 1 respectively, shows GPS: No GPS; only start light blinks once when powered up on gps, no light on safety switch, cable used: 8 pin to 4 pin

When plugged in GPS 1; shows GPS: No Fix; only led blinks once when powered up, safety switch light glows up and responds, cable used 8 pin to 8 pin

#2

Have you updated the firmware on the Here2? And is the internal switch set to CAN?

#3

I have kept the internal switch to I2C. Can you please provide me with steps to update the firmware.

While using I2C and CAN port I have positioned the switch to I2C and CAN respectively.

While using GPS 1 port, I have positioned the switch to I2C position.

#4

please use in Serial / I2C mode till we release the full CAN upgrade instructions.

1 Like
#5

@abhirup_sen I hope your problem is solved.

#6

My problem hasn’t been solved yet. Still shows GPS: No Fix when connected to GPS 1 port

#7

Check with another cable if you have one

#8

So please confirm
Switch is in I2C position, and you are connected to GPS1 position?

LESs are all functional?
GPS shows connected?
You are outside in a clear area?

#9

Yes

Only safety switch led functions, and HERE 2 start LED blink (cyant blue)
GPS : No Fix
No

@philip

#10

So this test is indoors?

#11

@abhirup_sen You are using CAN cable and trying to get it to work over I2C. Change cable to 8pin on both ends and try.

#12

No, he appears to have the serial cable connected correctly

But he is indoors

#13

Seems like he is using CAN cable. He hasn’t confirmed that he changed the cable and I have not got cyan blue in the 8 pin cable.

#14

But he says the safety button light is on. It can only be on with the unit plugged into GPS1 port.

A photo would be really helpful

#15

Gps:no fix indicates that he is successfully connected with the gps.

#16

Yes photo will clear the confusion. @abhirup_sen please post a picture of your setup.

#17

#18

#19

Leds blinking but accelerometer remains upside down and gps still no fix

#20

Set AHRS_ORIENTATION to zero