Here 3 update issue

Received two here3 gps with SW version 1.4xxx. then, I have updated the SW version of our here3 from 1.4xx to 1.7.3B7DB5CC.

Then, try to update the ublox firmware, download the ublox firmware update link. (Neo m8p rover).

I have used the u-center 21.02.

Then, the story starts. The u blox cannot update the firmware. Picture included.

What i did wrong? The gps is now fails to collect gps value.

Your baud rate is incorrect. Please try 230400.

If it still fail, connect to u-center then go to View→Message View→ UBX → MON → VER and see whether u-blox firmware information are showing correctly.
eg: Here+V2 User Manual - CubePilot

Otherwise, try other baud rates until it does. Then use the correct baud to update.

I still didnt get the mon-ver.

It ia connected through tcp. Cannot change the baudrate

That means you’re not connecting the u-blox chip. Not sure why, probably due to update fail.

By the baud rate setting, I mean the setting here:

Your settings are different from what demonstrated in the update instruction.

Alvin, may i get correct link for the ublox firmware image? Our here 3 has updated to 1.7.

@Alvin Im trying to achieve the same thing - ie to connect to here3 ublox chip via passthrough option in latest stable Mission Planner - and it does not seem to work.
There is no something listening on port 500 - when passthrough is set to 2, here3 restarted and passthrough port is set to 500 - but no data from ublox chip coming - althou u-center does not complain about the connection itself.

In my experience Mission Planner fails miserably to execute any SLCan operations reliably - thats something I have been observing over multiple MP versions (and with different computers/cubes/here2/here3 gps devices). Simple things like “Loading parameters” fail 7 times out of 10 tries usually. Getting MP to update here3 firmware usually requires a small miracle (it is unclear why it sometimes succeeds). Will attach MP console error screenshot/log - which seems to repeat with most of the failed cases.

Basically if I see this “could not find any recognizable digits” error in MP console everything fails afterwords. It is required to exit MP and connect again to Mavlink and start SLCan again. I cant explain why in some rare cases I dont see this error and everything works up to some point.

INFO MissionPlanner.Controls.ProgressReporterDialogue - RunBackgroundOperation
INFO MissionPlanner.Controls.ProgressReporterDialogue - Focus ctl
INFO MissionPlanner.Controls.ProgressReporterDialogue - in focus invoke
INFO MissionPlanner.Controls.ProgressReporterDialogue - DoWork
INFO MissionPlanner.Controls.ProgressReporterDialogue - DoWork Done
INFO MissionPlanner.Controls.UAVCANParams - Command to 126
INFO MissionPlanner.Controls.UAVCANParams - Value to 69
INFO MissionPlanner.Controls.UAVCANParams - Min to 56
INFO MissionPlanner.Controls.UAVCANParams - Max to 175
INFO MissionPlanner.Controls.UAVCANParams - Default to 78
INFO MissionPlanner.Controls.UAVCANParams - Fav to 50
INFO MissionPlanner.Controls.UAVCANParams - processToScreen
INFO MissionPlanner.Controls.UAVCANParams - about to add all
INFO MissionPlanner.Controls.UAVCANParams - about to sort
INFO MissionPlanner.Controls.UAVCANParams - Done
tå♫n:y♂ p​:relaxed::relaxed:û }D​:heart: AS2s¬y♂ q​:relaxed::relaxed:û áD​:heart: AS2▬à_ +:relaxed: :diamonds::diamonds::heart:
y∟ r​:relaxed::relaxed:▲ 4Ñ:heart: lá:bangbang:½è►+¼¢uä?Ñ♀|,§♀ º9YWy◄ s​:relaxed::relaxed:J
íY<GájAöó fmuy♀ t​:relaxed::relaxed:² trQ¼y+»"7á?↔Yy↑ u​:relaxed::relaxed:¶ ¬é:bangbang:½¢í¼å?ä?GájA?EÇ"uæ¬♫_ÿy​:diamonds: v​:relaxed::relaxed:♀+ y6é♫O·y♂ w​:relaxed::relaxed:û EÑ:heart: AS2ñ7y♂ x​:relaxed::relaxed:û cÑ:heart: AS2£ïy♂ y​:relaxed::relaxed:û
System.FormatException: Could not find any recognizable digits.
at System.ParseNumbers.StringToInt(String s, Int32 radix, Int32 flags, Int32
at System.Convert.ToUInt32(String value, Int32 fromBase)
at UAVCAN.uavcan.ReadMessage(String line) in C:\Users\michael\Source\Repos\MissionPlanner\ExtLibs\UAVCAN\UAVCan.cs:line 1766
at UAVCAN.uavcan.<>c__DisplayClass1353_0.b__1() in C:\Users\michael\Source\Repos\MissionPlanner\ExtLibs\UAVCAN\UAVCan.cs:line 274

After playing around more with MP SLCan mode I would say it does look like COM port connection issue - and errors seen from MP console are just a result of malfunctioning serial connection to cube (wrong baud maybe?).

There is one clear indicator of “successful” SLCan connection to here3 - its uptime counter must update every second in the table view (ie make sure its not stalled). If it does not update - then you have “failed” connection and trying anything else is pointless. One must start from disconnecting/connecting cube to laptop again - ie usb serial connection seems to require full reset at hw level to be able to succeed later on in SLCan mode.

And on some rare occasions everything works - and allows you to update ublox fw as well. Havent found a reason yet why it suddenly works.

Your here 3 is now 1.5 SW version? Where did you download the ublox firmware?

Mine is 1.7 and i still didnt get which suitable ublox firmware that i should flash to my here 3.

Thanks alvin.
Finally get to flash firmware from ublox to here3.
But still didnt get any satellite reception. Maybe wrong ublox firmware. Which firmware should i use?

You may get them from the u-blox website, everything else are same as Here+v2

This is correct.

This is because the Cube has entered SLCan mode. The only way to get back to serial mode is a reboot.
In early mission planners/ardupilot firmware there are bugs in SLCan making them sometimes hard to connect. Try to get everything up to date.
Also, note there is a message in UAVCAN screen
If you are using Cube Orange, you can also try to select the orange’s SLCan port at the top-right corner in mission planner. Then SLCan directly from the port.

But how can i get the correct firmware? What chip does here 3 use?

No I managed to update here3 fw to 1.7.3B7DB5CC first (beta channel). Here3 u-blox M8P rover firmware I got from the link in the here3 manual (look for rover fw from the documentation & resources list):

You have to set passthrough option to 1 (instead of 2 thats for flashing only) - in order to see GPS data in u-center.

Here3 is M8P rover. Here is the direct download link to v1.43 I used:

@Alvin MP was latest stable 1.3.75 build 1.3.7883.26333. Arduplane fw was also latest stable 4.0.9. SLCan1 connection with Orange Cube fails 9 tries out of 10 or so (ie MP shows connected yet uptime counter will hung after 2 secs/updates and nothing works at this point). Something is fishy with MP SLCan connection implementation.

Tried to update another here3 ublox firmware but it is also failing in the middle of the ublox fw flashing (besides the usual MP SLCan connection issues).

@Alvin any ideas what to try next? Or this unit is faulty and should be returned for RMA?

Solution: switched to another Orange Cube and standard carrier board - and voila - ublox firmware update finally worked.

What the heck is going on with Cubes, carriers, MP and SLCan connections reliability - could it be also hardware issues involved here?

1 Like

Can you try to update the bootloader on Cube Orange from Mission Planner?
Also, can you try if another CAN port have the same problem?

Constellation configuration cannot be enabled.

Thanks a lot for the specific tips and instruction. Managed to get 1 of 2 here3 gps to be working again. But, the led doesn’t turn on after it gets gps fix. It stays yellow blinking. Is it same with yours?

In my case no. But correct me if Im mistaken - leds signal also other problems that come up by arming checks (not only lack of gps fix). You might try to disable all arming checks and see if here3 leds turn green once gps fix is achieved.

Finally got here3 flash using beta.

For user out there, if you got your here 3, never do update or you will have problem.