Here 4 rtk base not surveying in Qgroundcontrl


I have purchased latest here 4 rtk GPS & base station module. I am using PX4 & Qground control. As per the instructions, I am connecting the here 4 rtk base, the survey in is not getting activated and it showing zero satellites and rtk streaming.

Here + base station was plug in solution. Is it because QGC, is not supporting Here 4 rtk base station?

Hi Vishal, can you try updating the Ublox module on Here4 RTK Base with latest firmware downloaded from here NEO-F9P module Firmware Update section. You will need to use Latest u-center application to do so.
Also please note that L5 signal is by default disabled on Neo F9P modules, so you may need to enable that from View → Generation 9 Configuration view . Also follow the instructions here to override signal health . We will work on getting this automated in QGC.

Above is already automated on Here4 Rover, just ensure that you are running atleast v1.13 firmware Releases · CubePilot/GNSSPeriph-release · GitHub and have parameter GPS_DRV_OPTIONS set to 32 for enabling and overriding L5. No other changes should be needed on Here4 Rover.

Which PX4 version are you using?

I will look into this, probably next week.

Hi Siddharth,

I tried as you said. Still, the survey in is not getting started.
I have done updating firmware and changed the settings as you mentioned.

I also followed as mentioned in the pdf. But, it is not working.

I am seeing the fence led is Blinking strongly ON in here 4 rtk base, but not in here + base. Does this have something to do with QGC? Does QGC have support of ublox NEO-F9P or it have only ZED-F9P support?

@JulianOes I am using PX4 v1.13.2, here 4 rover has no issues. I want to use the here 4 RTK solution, which have higher convergence.


Seems like after commenting out enabling jamming monitor message in ubx.cpp. Survey in is getting started in Qground control.

Can anyone provide reason behind that? Also, does this affect any performance of rtk streaming?
Will be doing flight test next week.

@VishalV01 you’re right! Nice catch! How did you find that?

It turns out the valset is still valid but needs setting in a separate step.