Here4 RTK Base not surveying in QGroundControl


I’m trying to get my Here4 RTK Base to work but it’s not surveying in. The icon never goes red and immediately jumps to the white status, displaying “RTK Streaming” and “Satellites: 0”. I am using ArduCopter v4.5.3 with QGroundControl on Mac M1. The Here4 rover works perfectly fine.

In terms of what I’ve done to attempt solving this problem, I ran into someone else on here having a similar problem:

I updated the Ublox module with the latest firmware on the Neo-F9P site, as well as went through all the steps to enable L5 signals and override signal health. OP figured out the problem somewhere in code that had to do with enabling jamming monitor messages, but that was for PX4.

If anyone might be able to help I’d greatly appreciate it.

@leejavaa have you tried Mission Planner to configure and use Here4 base. Can you confirm if it works there?

Hi @sidbh ,

Thanks for the response. I use mission planner on my desktop PC instead of my Mac. I can confirm that it works in mission planner as shown here:

However on QGroundControl the icon remains white and it does not survey in :frowning:

Screenshot 2024-06-14 at 07.05.48

@leejavaa my suspicion is that QGroundControl does not support configuring ublox Neo-F9P module for use as a base. I will recommend you contact QGC developer for support on this.


Have you tried with QGC v4.4.0: Release v4.4.0 · mavlink/qgroundcontrol · GitHub

Hi, Julian

Must have missed the update. Yes it works perfectly now. Thank you so much!

1 Like