Here2 CAN High HDOP, Here2 Serial HDOP OK


I have realize on my new drone the HDOP was very dificult to get less than 1. In fact, it never did. I though may was a bad day, but then I did some research in the forum here and I saw there were more cases of this.

Today I have try again, in a place where I know is good GPS signal. In fact I try first with and old drone with BackCube and HEre2 Serial, and I got 0.9 HDOP very fast.

So I have try again my new setup, OrangeCube 4.0.4, Here2 CAN, and again as the same as the first time, the HDOP was 1.9, 2.1, no less than that.

So, I have try 2 GPS on the same orange cube, one on the serial and one on the CAN, and the result was the same, the Serial got very good HDOP, and the CAN wont.

May be im missing something the the GPS CAN setup?

Originally the Here 2 did not support HDOP over CAN but there is a Beta firmware for it in mission planner.

Just update it and it should work.

1 Like


As I understand, the HDOP its a kind of rate of the GPS precision, right? So this is mean the presicion on the GPS over CAN is not good? Or its just the FW can handle that number?


Nothing related to the actual precision just reporting into the FC is wrong . Try the beta firmware and it should be better.


great, I will, thanks!

Great, it now finally reports correctly to the FC. Is there any changelog available, or do you know if anything else has changed?

Beta firmware for what? HERE2? How to find it in mission planner. I run AC 4.0.5

1 Like

You need to connect via SL CAN and then click update.

thank you. I actually never tried this method. o always followed manual on there page, which i guess allowed me to download non-beta firmwares.

Hi! 4.0.5 will fix this? do you know? Thanks!

Any solution? Facing the same issue

Just update the firmware on the Here2 using SLCAN. Has been working great for me for almost 2 years.

Thanks, This worked for me. The problem was when I had followed the update manual (offline bootloader and firmware update) from cubepilot website the firmware had updated to SW V 1.3.something. I thought this is it and the update is successful, but when I updated it again online just after this procedure it changed to SW V 1.7.something and now HDOP is never going above 0.7.

Thanks to all members