HERE2 GPS multiple problems

#1

I’ve got HERE2 GPS - came with CAN mode enabled and CAN cable fitted by default.
Switched to Serial mode and fitted serial + i2c cable for Cube black GPS1 port.
GPS was working on GPS1 port - but failing configuration checks - seems to be known bug with older HERE2 firmware - as discussed here: HERE2 GPS failing configuration checks. HERE2 LEDs were also not working in serial/i2c mode (just Power led).

Ok - tried to switch to CAN mode (Cube black, arduplane 3.9.11) - in order to check if it works with CAN and to update GPS firmware. Got LEDs working in CAN mode. But cant get GPS detected in CAN mode. Also not able to list any parameters when in SLCAN mode (in order to set node ID for example). After clicking “SLCAN mode on CAN1” button - nothing appears in the list. When using CTRL+L combination on Mission PLanner (v 1.3.68) "SLCAN mode … " buttons are greyed out alltogether - yet they are active if going via Initial Setup -> Optional Hardware -> UAVCAN

How to debug this further? Is there any special driver needed for SLCAN mode - that did not came with Mission Planner?

#2

Update: HERE2 GPS started to work in CAN mode with arduplane 4.0.0beta3 - because it probably has dynamic node ID allocator? Still SLCAN mode does not work - not able to see GPS firmware params.

(Ian ) #3

Remember on many of the carrier boards Can ports are labelled the wrong way around.

Also SLCan has been behaving really strangely in later builds but was working in June daily, Iv not tried it on current Beta 4 but will in a minute and let you know.

#4

Yes I noticed wrong CAN labels before - so I did put HERE2 GPS into CAN2 labeled port (as its the CAN1 in reality). Im guessing that arduplane 3.9.8 did not have support for dynamic node ID allocation on CAN bus - and 4.0.0beta3 does - so thats why it started to work. But cant explain why SLCAN mode does not show anything (but Mission Planner serial connection is fine).

#5

This seems to be quite fresh overview about the current CAN status in Ardupilot: https://github.com/ArduPilot/ardupilot/issues/12165

As it reads - “current stable fw releases have no SLCAN and no DNA”.

And here we have a HERE2 product - that defaults to CAN mode and firmware update/settings require working SLCAN and its shipped firmware version does not fully work in legacy mode… nice.

#6

Managed to get SLCAN working just for ONCE (with 4.0.0beta3, not sure why it worked suddenly) - enough to set static node ID (so that Here2 would be usable with arduplane 3.9.11 - which does not have DNA) - and to try updating GPS firmware.

Here2 GPS firmware did show 1.1.72… version - and Update button said “No updates”. I could not find any clear information what could be the Here2 GPS latest firmware version. Does anybody know?

No luck afterwards to get SLCAN mode working again - after disconnecting…