HERE2 GPS failing configuration checks

#1

What could be the problem with HERE2, I2C mode (legacy) set with the switch.
Also U-center is unable to detect firmware version of the U-blox module.

This is the error.

GPS 1: u-blox navigation rate configuration 0x1DFF
PreArm: GPS 1 failing configuration checks

Also very limited amount of messages available on u-center (debug mode on).


image

HERE2 CAN issue
#2

@jschall

#3

I am also having the same issue on 2 out of 3 drones i’ve built with the Here2 and Cube black. I have followed the what the service bulletin said and have that prearm check giving me issues.


I would upload the parameters I am using but the .param file isn’t allowable to be uploaded as well.
Sorry to cross post but here is a link to the a thread I started earlier today on the ardupilot forum in case it helps. https://discuss.ardupilot.org/t/arducopter-3-6-8-running-on-cube-black-gps1-failing-configuration-check/42229

#4

Can you double check the wiring? The “failing configuration checks” message suggests that there is a problem with the UART transmit line that sends data to the GPS, but the fact that it detects the GPS at all means the receive line is fine. Are you using the cable assembly that comes with the GPS?

#5

I have triple checked the wiring, I swapped the cable completely with a known good gps cable and still had the failing configuration check come up. I also installed an old HERE gps module I had lying around and the failing configuration check went away. But when I install the HERE 2 that came with the cube black the configuration check message pops back up.

#6

I have exactly same thing.

I have swapped the cables to a known working ones and problem consists.
When I replace the non working HERE2 to a known working HERE/HERE2 problem goes away with the same cable.

I have 4 HERE2 units out of 10 not working.

#7

I have had 6 HERE2 units not work properly so far. I’ve sent them back to the distributor I got them from, and they are hopefully going to send me ones that do work properly.

#8

I’ll throw mine in the pile too: I have 3 out of 9 HERE2s with the same error (0x1DFF) in I2C mode. I have likewise tried swapping cables, cubes, etc.; the issue follows the GPS unit regardless of other hardware.

The error goes away and the copter becomes armable if I set GPS_AUTO_CONFIG = 0. Of course, that means the GPS might not be configured correctly, so that’s still a no-go.

#9

can one of you see if you can download the parameters via u-center?

#10

Hi @philip,

I’m not able to load any configuration info out of the u-blox module. I cannot enable all debug messages due the u-center unable to see firmware version. I cannot manually poll messages other than those already available.

Please see video.

Same behavior on all units that are not working with autopilot.

#11

Ok, thanks.

Working on a solution, we will release a firmware update ASAP for the GPS, for updating via mission planner.

@jschall

1 Like
#12

I have the same issue with using a regular HERE(+), using Ardupilot 3.6.8
Having exempted that portion from the arming check, things seem to be operating fine and I am getting a RTK float solution. But a firmware update for this version as well would be appreciated, so that the full arming checks can run.

#13

On a regular here plus, the only reason you will get this error is broken wires, or bad parameters

#14

I have been able to do some more tests (with the regular HERE+) today, with slightly changed configuration and was able to correctly pass the checks now.

#15

@Zeke @Morso @Anubis

I’ve developed a fix for this issue. The fix involves updating both the bootloader and the firmware. Files and instructions are attached below:

EDIT: see https://docs.cubepilot.org/user-guides/here-2/here-2-instruction#step-10-flash-the-bootloader-updater for instructions

1 Like
#16

I tried this with a previous version (rc2) on the six bad units I had. The updates were successful, but the error eventually reappeared and the GPS had poor performance.

I see the firmware in rc3 is different. I’d try that, but I have already returned the units after the rc2 update didn’t help. Would we expect rc3 to work if rc2 didn’t?

#17

Yes, RC3 fixes those issues

#18

I’m having the same issues.

I tried switching to CAN protocol where I followed THESE instructions. I also did UPDATE of GPS as it was available. But after that I cannot switch back to UART/I2C. It gives me the same error as described above. MissionPlanner reports that it cannot configure GPS settings, and when I try to access it using U-Center I cannot poll any data from GPS (gives time out error) and also cannot update firmware. Looks like HERE2 is bricked.

I tried fixing this issue using using RC3 bootloader and firmware but I when I click to “SLCan Mode CAN1” it just disconnects aircraft from Mission Planner and nothing appears in list. I checked that switch inside HERE2 is switched to CAN, and it is connected to CAN2 port on Pixhawk 2.1.

Any idea how to unbrick HERE2 GNSS Module?

1 Like
#19

Have a look at the topic on CAN firmware update issues. This is a known Issue, and a solution is being worked out

#20

I have a problem too with the Here2, I have not fix…

Immagine%203