Here3 gps firmware update fail

I’m trying to upgrade here3 gps firmware bia doc, But It does not work.
Mission Planner version : build 1.3.7747.6708 (latest beta version)
Holybro Pixhawk 4
used latest ardupilot firmware.
After tried to update, SW version is set to 0.0.0 / SW CRC 0
when connected, mode : maintenance, health : critical.
However, after pushing, update beta, done fw downloading, it starts update with
but after few seconds, FAIL, return to MAINTENANCE and health CRITICAL.
I tried multiple times with different computer and reconnecting multiple times, but no better results.

Is there other way to update firmware?
And where can I get help?

When you press the menu->update button, 2 windows should pop up.
What did you choose for their option?

I tried both of them, both beta and stable version.
Additionally, every time updating, it takes different time to SOFTWARE_UPDATE to MAINTENANCE. Updating ends with different progress bar. Sometimes ends immediately after push update, or takes few seconds with almost 30% of progress bar. but never reached more than 30%.

Thank you for your help.

What is the current SW version of your Here3?

I remember SW version was 1.5… before tried SW update. Now 0.0.0.
I tried SW update in order to use with PX4 autopilot FW. I did exactly same instruction in manual, i changed uavcan_node_id and connected to PX4 autopilot 1.11, However here3 not working properly (no lighting of here3). So I had tried to update SW of Here3.

Maybe the firmware inside is corrupted, you may contact your local distributor for RMA

I am currently having the same issue with the exact same setup… Can confirm that the firmware that came with the here 3 was not corrupted. The RTK worked on arrival but attempting to flash the latest firmware on it broke it - I have found no solution to this. Can someone help please?

1 Like

I am having the same problem, stuck in maintenance mode, any fix yet?

Solved, latest arducopter version fixed update problem :grin:

1 Like

Hi Camilo,
Did you fixed this?