Here3+ no GPS fix

We have several new Here3+. Every of them has no GPS fix even after 3 hours outside (I see uavcan_equipment_gnss_Fix2 message gets with 5Hz, but data is zeros).
I also tried to connect to M8P-2 via u-center (like described in Here3+ manual) to load almanach, but there is no “passThrough” parameter in Here3+ params. When I try do update M8P-2 software (like described in Here3+ manual) in u-center, it gets an error " 0.3 WARNING: SW Version information seems corrupt! 0.3 ERROR: Could not get correct ROM size"…

Does somebody know the way to connect to M8P-2 in Here3+ (in particular to load almanach)?
And what is the possible reason of few new Here3+ deviced has no GPS fix in described situation?
And maybe I can somehow to connect the developer to get the product support?

Hi Nikolai,can you please share a screenshot on your MP HUD?

Hi Mike, here it is:

Can you re-flash Here3+ firmware with MP ?
What is your LED indication on Here3+?
Can you please check the relative parameters ?

-Can you re-flash Here3+ firmware with MP ?
In UAVCAN window i press Menu->Update, then I see “Download FW”, then “File send complete”. I don’t sure does it mean that update is OK ot not.

-What is your LED indication on Here3+?
Right after I connect Here3+ to CAN1 (Cube Orange), the LED became solid White (or light Blue), and the color is always stays the same. No blinking or color change at all.

  • Can you please check the relative parameters ?
    Yes I checked all the parameters, actually they are the same like in our Cube Orange with Here3 (which works OK). But I think the parameters is the second step. First step is that I have to see uavcan_equipment_gnss_Fix2 message with data instead zeros. Or I’m wrong?

An additionally question: can I use this port pins (on the photo) for to connect to the M8P? Or what is the function of this port (I find nothing in the manual)?

Yes, you can use ‘‘USB to TTL module’’ connect your here3+ to u-canter.
But the case is water proofed, so there water proof feature will be affected once open the case.

Thanks, could you please provide me pinout of this port to understand how to connect USB to TTL module?

Don’t you have this port pinout?

I will PM you.

1 Like

hello there i am also stuck with the same error how can i fix this please guide me with this.

Unfortunately, nobody helped to solve the problem. I was really surprized that the developer has no real documentation and technical support. It’s like some toy, but not serious device.
If I solve the problem, I’ll let you know. And you please share me the info, if you’ll find the way to make here3+ alive.

I got the 3dfix gps but only able to connect with more then 5-6 satellite at a time. so i thought its the problem of firmware so i decided to update the ublox chip but thats not happning…

can you share me the pinouts too.

May I know your oerating environment ?
What is your LED indication on Here3+?
Can you do a swap test with another GPS unit ?

  1. i was operating gps on open ground though i was getting 5-6 Satellites.
  2. led is blinking in yellow color and when i arm it turns to solid green colour.
  3. i dont have another HERE 3+ gps for swap test.

Hi, could you tell me please, how did you try to update ublox chip? Like in user manual described?

yes i have done as it described in the user manual, but i cannot find the PassThrough parameter in UAVCAN of here3+
this is what they have shown parameter list on the user manual:

and here is the parameter list of mine:

i cannot find the passthrough parameter in my list.

Yes, the same at my side.
Looks like the reason is in this note in the user manual:
" 4. HERE3 u-blox Chip Firmware Update

Here is 3 + U-Blox firmware update method will be released when a new firmware comes out for the M8P-2, the here3+ has the latest firmware at launch, and we will update here if a newer version comes out."

I think, this functionality just doesn’t implemented in Here3+…

yes! but I am getting only 5-6 satellite at a time. i think its only getting connected to GPS satellites its not getting connected to GNSS or Bidoue Satellites. do you have any solution for that? there must be problem with GPS_GNSS config.