Negative Current Reading on Kore Carrier Board

(doug s) #1

Hi, i am trying 3 brand new kore and cube (i have 3 kore and 3 cube boards) , i read -4,9A, -4,2A and -3,5A while 0 amps (nothing connected) for each kore board, i tried switching the cubes. I use parameters given in below;

|BATT_AMP_OFFSET|0.45|
|BATT_AMP_PERVOLT|50|
|BATT_CURR_PIN|3|
|BATT_MONITOR|4|
|BATT_VOLT_MULT|15.3|
|BATT_VOLT_PIN|2|

Do i need to calibrate batt_amp_offset? Because i did not make any current or voltage calibration with my older kore boards.

#2

Which cube?

(doug s) #4

Pixhawk 2.1 Cube Black

(Yasir Khizar) #5

@doug, did u find solution to this problem? @Julien, i am also facing the same problem. While using Kore Carrier Board (Cube 2.1) with configuration parameters as mentioned in the spec sheet, the current reading is -ve (3.5A, 3.7A, …) on the Mission Planner screen. i have checked the connections and could not find any obvious issue. Can u plz help/guide in this regard…
Thankyou

Regards
Yasir Khizar

(__Airbot Systems) #6

It could be negative when you are connected in USB first.
Connect your battery first then connect USB. It is still negative ?

(Yasir Khizar) #7

@Julien, I did not connect usb. Infact i have been using RFD900x for the telemetry data. I am plugging in the power through battery to Kore Carrier Board and the sign of current is negative in MP.
Regards
Yasir Khizar

(__Airbot Systems) #8

So you confirm the battery is plugged and you have the same parameters than Doug posted ?

(Yasir Khizar) #9

@Julien, yes i have confirmed that the parameters are correct. I have checked them twice. However, i did not carry out any voltage or current calibration. In addition, i am using 22000 mAH LIPO Battery. The quad copter is still on the ground with motors connected. I think the current drawn from battery should be in milliamps compared to negative current.

Regards
Yasir Khizar

(doug s) #10

I tried 3 different kore boards and 3 different cubes (with usb, with telemetry and battery), voltage reading is ok but current reading is negative, When i change batt_amp_offset i can make it 0A when it is 0, then a little tuninh with batt_amp_pervolt i can read suitable values for current but i think this is not a solution.

Right now i will use an old cube and kore (i have mounted on my drones) then find whether the problem is on cube or kore.

(doug s) #11

I think i have found a reason,

Yesterday i tried 3 different cubes with 5 different Kore boards :slight_smile:

With using brand new Kore boards rev 1.4. A (which has a sticker on it, newly bought ones) current reading is -3,7A, and -3,9A

With using my old Kore boards rev 1.4.B (which i bought about 9 months ago) current reading is 0 and 0.1A

I think there is a problem on current reading of rev A Kore boards. Interesting part is that i bought these guys recently.

(doug s) #12

It is not a solution but; try to change these 2 parameters, i think your board (Kore) revision is A too,

|BATT_AMP_OFFSET|0.37|
|BATT_AMP_PERVOLT|67|

(Yasir Khizar) #13

@sierra_spektreworks, @philip, @Julien, can u plz guide/help in regards to negative current reading problem via kore carrier board on mission planner…
Regards
Yasir Khizar

(Daniel Laks) #14

The 200A Hall Effect sensor needs to be calibrated at 0A to get correct readings. The parameters in documentation are based on an average from the sensor’s manufacturer, which is “good enough” for casual use. But if you’d like to calibrate it to get more accurate readings about the zero point, follow these instructions. This calibration should only ever need to be done once per board:

  1. Using a bench-top power supply or a battery, use alligator clips to connect the positive wire to the in-board bus bar of the current sensor. This will energize the entire board, but bypass current through the current sensor. This way, you can get a true 0A reading.

  2. Power up the board in this configuration and connect to Mission Planner. Set the following parameters to these temporary values:
    BATT_AMP_OFFSET = 0
    BATT_AMP_PERVOLT = 1

Doing this will cause Mission Planner to report the direct analog voltage it is reading from the current sensor.

  1. Go to Initial Setup -> Optional Hardware -> Battery Monitor. In the calibration box, read the value for “Current (Calced)”. That is your offset voltage at 0A.
    hall2

  2. Set the offset parameter to the value you read in #3:
    BATT_AMP_OFFSET = [value]
    BATT_AMP_PERVOLT = 50

  3. Power down and reattach the positive cable to the main solder pad. Your current offset voltage should now be calibrated.

1 Like
(Daniel Laks) #15

Calibrating the 0A offset removes most of the error from the current readings. If you require the full accuracy that the current sensor offers, you will also need to calibrate the BATT_AMP_PERVOLT parameter. I don’t recommend doing this unless you are familiar with high-power electronics. For most users, a value of 50 is good enough.

You will need an accurate external load of some kind, such as a programmable artificial load or precision power resistors. Attach the load to the ESC power pads and back-calculate the multiplier based on the equation of a line. Set the OFFSET and PERVOLT parameters to 0 and 1 (same as step #2 in previous post) so you can read the direct analog voltage in Mission Planner.

Representing the equation of a line as y = mx+b:
y = the current in Amps (this should be known based on your external load)
m = BATT_AMP_PERVOLT
x = analog voltage from sensor
b = BATT_AMP_OFFSET

You can solve for m, as you will know all of the other values. I recommend you choose at least 2 current values and take the average result.

2 Likes
#16

Thanks Dan!