Old HERE2 stuck in green light limbo - SOLVED

I’ve been struggling with an old HERE2 stuck in solid green after updating the bootloader and firmware. no matter what versions of MP or copter I use (betas, stables, nightlys), I can’t get it to be recognized through SLCAN. nor can I pick it up through the UAVCAN GUI tool.
i am currently on MP1.3.70 and APC4.0.1 stable. have tried beta on both, MP 1.3.68, 1.3.64, etc, as well as whatever APC4.0.x-beta was available last night, among many others.

i have another HERE2 that i had no problems at all doing the update to CAN. after looking at them closely, they are different boards… could they be different enough that it is actually a hardware issue?

the one im having trouble with is a CANHERE R1 board. the one that i had no issues with is a CANHERE R2 board. this is in the silkscreen just to the right of the main plug on the board.
from some of the other posts on this topic, this may be a common detail in all of the ones that get stuck, though i cant say for certain.

i am currently on MP1.3.70 and APC4.0.1 stable. have tried beta on both, MP 1.3.68, 1.3.64, etc, as well as whatever APC4.0.x-beta was available last night, among many others.

if anyone has a tried and true method for this, with specific versions of MP and Copters, not just “beta” or “nightly”, that might be helpful and id give it a shot.

1 Like


here is a second strange thing going on with this here2 gps module:

i tested today to see if it worked in i2c mode, and it does. passed compass calibration with good offsets, safety switch functions, attains satellites quickly, etc. (didn’t test fly as i dont trust it yet and its very windy today, but took it into the parking lot to let it get a good gps lock)

the odd part is that the LEDs are staying solid green regardless of what i do. i have double checked gps_type=1 and ntf_led_type=199.

i’m perplexed and i hope yall can help me figure this out. i’d like to be able to use this GPS, specifically in CAN mode, but i’m wary of it right now.

Stuck in Green would indicate that you have updated the bootloader but not updated the firmware correctly via SLCAN

1 Like

ok that’s kind of what i expected.

any surefire ways on how to get it out of this loop?

1 Like

any more feedback on this? anyone who you can point me to for advice?

i don’t want to have to scrap a $100 piece of hardware because it failed to upload firmware correctly while following the recommended procedure for doing so.

It’s not scrap yet. Try connecting again via UAVCAN tab on Mission planner. Once connected, upload the second file that you have downloaded from here2 docs(firmware file). Once updated you’ll get normal LEDs.

thats the thing though, it no longer shows up in slcan or using the uavcan gui. and it did before, which is how i was able to upload the bootloader.

i have another one that i’ve been able to do the CAN update with no issues. so i know how it should go,and this one didnt work. i know im not the only one with this issue and im hoping that one of the devs knows a way to reliably connect to it and either re-upload the bootloader and start the process over, or flash firmware onto it.

1 Like

Contact your reseller and exchange it.

wanted to add to this after solving the issue finally.

followed @Michael_Oborne 's advice on this thread and was able to get my HERE2, that WAS stuck in bootloader, to be recognized and finish the firmware update.

AC4.0.1 stable and MP1.3.70 stable. connected a known working here2 already in CAN mode, viewed it through SLCAN. while in SLCAN, i physically disconnected the working here2 and plugged in the stuck here2. it was immediately recognized in SLCAN and i was successfully able to upload the firmware onto the stuck here2 and get it working correctly.

did another reboot after just to make sure, checked hw IDs and sure enough, GPS recognized on CAN, lights worked, etc.

Thanks @Michael_Oborne