Unable to update here2 with master firmware

  • After updating gree led stay in green mode , when I connect again in UAVCAN mode unable to connect
  • Led keep in Green Mode
  • Is there any other way to upagrade here2
  • master firmware is not working ,is there any other firmware which is working


I had the same issue. I tried it with one of the old beta mission planner and was able to upload the firmware part of the process.
Hey! @Michael_Oborne
These were kind of inconsistency i was telling you about in one of the previous posts.
What would be the cause for this?
Thank you!

1 Like

what version mission planner were you using? i have tried every version from 1.3.64 to 1.3.7 and im stuck in the same place.

The sold greenlight is when you do the bootloader update firmware

You need to then put a normal firmware back on it.

I think the issue might just be not finishing all the steps

Also in this image you are plugged into can2. Label may be incorrect on the case

Hey @Michael_Oborne
I have updated like 50+ here2 GPS. I know the process of bootloader and then firmware. I wanted to ask you about consistency of operation. For some GPS modules it just gets stuck after bootloader is flashed and lights are green. After that, it’s really hard to connect to slcan again. I have experienced this only with couple of modules. Since I saw one more person facing the same issue i wanted to know whether any improvements can be done to avoid this.
Thank you! :grin:

1 Like

Fair call, green at runtime.is normally GPS lock indicator. It also could be a can param set somehow to chnage the led’s to that colour.

To verify put a cube into slcan mode with a known good GPS. Then unplug it and plug in the other one to test. It should come up as expected. Watch the uptime counter. Should be updating every second

Without disconnecting slcan I will add

can you provide that firmware,I am in trouble


firmware is there

1 Like

i used this method yesterday and got my here2 updated.

i was on AC4.0.1 and MP1.3.70, stable on both.

1 Like

hi, i’m having the same issue (stuck on green after bootloader). i don’t have another gps at the moment. is there anything that can be done other than sending it back to the vendor?

i tried using can 1 and can 2 ports, no change.

1 Like

i’ve tried the last 8 versions of mp and ap…still no change.

Has anyone found the solution to this?
I am having the same problem with my Here3. After a few seconds, the uptime stops and I can no longer send commands or get params from the GPS.

Did you try to update the bootloader on Here3? Here3 shouldn’t required bootloader update.

If you are talking about simply connect to Mission Planner, try to reboot the Cube and go through the whole SLCAN things again.

1 Like

I spent two hours trying to get my Here 2 working. I could view the device in MP but nothing else worked. In MP the Hardware version showed 2.0 and the SW version showed 0.0.0 — Repeated attempts to flash either the bootloader or new firmware were not successful. The flash would start and MP would display a change in the mode to Software_Update (briefly) before it reverted back to Maintenance mode. I was unable to view the Parameters either.

My solution was to install UAVCAN GUI Tool. Once I set my local node to an arbitrary number, 100, I could then connect to the Here 2. Once connected I was able to flash the Bootloader and then flash the firmware files from the Here 2 firmware guide. I was absolutely unable to do this via MP no matter what I tried. Once the firmware was updated I connected via MP and was able to update the parameters, set a unique ID (20) and everything started working as expected. The HW version changed to 2.1 and the SW version shows the 1.3xxxxxxx