QGC freezes when recording video

Hello,

When I record video with OGC in the ground station the video stream freeses for several seconds but than recovers normally. While waiting for the video to recover, in the past I could navigate with the map display.

Today it got worse: First the video did freese and did not recover and then after some seconds whole QGC freezed. No Map update. I pressed RTH but it obviously did not work. I killed the QGC task, restarted QGC and found my plane far, far away…(I was in position mode with a FW).
With the last watts I managed to do an RTH.

Any idea, what caused the problem? Anybody having the same issue? I found an old task describing similar problems, but from the time before the “stable” version and without a solution.

Can anybody help?

Best regards
Peter

Could it be the Herelink overheated?
Were other functions still working when the screen was frozen?

Hello Alvin,

It was a pure QGC problem: After killing the task and restarting OGC I had the full control again. The outside temperature was around 6°C - so temperature should have been no problem and the rest of the remote control (including sticks) on android level worked fine. But without working camera and map and MAVLINK buttons I had no chance to control the plane.
So the plane meanwhile flew away with 20m/sec while I restarted QGC. Luckiliy I was in POS mode so I did not loose hight.
Maybe it is a good idea to have a RTH button directly programmed without MAVLINK.

Did you have Solex working in background when using QGC? It may causes some problem.

QGC on Herelink don’t have mavlink button function. You map them with sbus in Herelink setting app.

The RTH button can be set through any ground control station, by allocating any button to set a flight mode.

Solex was not running. I have PX4 on my FC and Solex does not work with it unfortunately.

On the Herelink QGC does assign buttons to mavlink functions like flight states. It’s the recomended way, preferable over SBUS in the manual.
During my frozen QGC all SBUS functions were working while the mavlink commands via QGC did not.

Have you tried to re-flash the firmware on Herelink?
That’s the easiest way to re-install the QGC.

@Alvin, @Herzjung we have also been using QGC in herelink in our 3-4 quadcopters and we have exactly the same problem ever since. The problem persisted in the old firmware as well as in latest herelink stable version such that when we press the recording button, QGC gets stuck and the screen freezes out for about 5-20 secs… In order to record the video, we tried using Mission Planner connected via udp but the recorded video had poor quality. Therefore, we adopted the use of vlc player for video recording and is thus serving our purpose. The second problem we have observed (in some cases) is that video starts lagging after some time passes by or may gets distorted in Mission Planner (connected via udp or usb cable or Wifi Router). We have tried various computers i.e. desktops, laptops, tabs but the problem persisted. Is this problem related to herelink release or Mission Planner V 1.3.74? The last issue we have been facing is regarding maps. Wr use to download maps from qgc in desktop (which works ever so good) and copy the file to herelink. The herelink QGC, however, would alwaz require to be connected with 5g (atleast for a single time) to run properly. This seems to be a bug in herelink qgc release. Any help wud be appreciated… @Michael_Oborne, @philip
Thankyou
Regards
Yasir Khizar

1 Like

I did some testing - as long as I stay in the vincinity everything works fine. OGC crashes when the transmission signal get’s weak. I can trigger the crash of QGC by flying in the same area, where I have some shading of bushes and the signal gets weak.

Best regards and merry christmas
Peter

If this problem exist in multiple copters across various version, it may be related to the hardware setup.

Can you tell more details about your setup? Such as the Camera, length of HDMI cable, how you power the Herelink, etc.
A picture will be great

@Alvin, thanks for ur reply…
Actually the video stability problem doesnot lie at the groundend herelink i.e. video is stable on herelink but when we connect herelink to some other laptop/pc/surface tab via udp we have seen video lag issues in the secondary display i.e. laptop/tablet… The video starts normal but as time passes on, the video lag tends to increase… I would like to know that wifi inside herelink is sufficient enough to support video streaming? Are there any requirements for our wifi router for stable streaming? Since we have been using Mission Planner (V1.3.74) as our secondary display unit in our tab/laptop, can this be related to MP or do u foresee some other issue?
The problem related to video recording was there in old release as well as latest stable release… We didnot put effort on solex but in qgc, the video recording is alwaz a problem, the app/screem gets stuck and we need to wait till all is ok… Since video recording is essentially a part of our system, we wud like some advice from cubepilot team regarding this issue…
The last problem related to maps is that we copy the downloaded qgc maps but if we connect our copter, the maps are not displayed… Thus, for short time, we connect herelink to 5g and atonce the all the maps are displayed on herelink…
Your help wud be greatful…
Thankyou
Regards
Yasir Khizar

Hi, @Alvin
Links shows video recording problems :

  1. When we press the video recording button, the qgc screen gets stuck for 5-10 secs as shown in the video… As the recording button is pressed, the pan/tilt command was applied and the camera was moving but the screen is freezed; though In the background, the video is being recorded…
    https://drive.google.com/file/d/1S05BYkH9XStdfZSJ4UgcnYCIrYzv9O51/view?usp=drivesdk
  2. In the 2nd case, when the video record button is pressed, it doesnot go in to recording… And we need to press 2nd time or likewise on 3rd or 4th iteration, video recording starts and again it gets stuck for 5-10 secs…
    https://drive.google.com/file/d/1S05BYkH9XStdfZSJ4UgcnYCIrYzv9O51/view?usp=drivesdk
  3. Moreover, we have checked the recorded videos. They starts from 18 secs, 20 secs, etc.
    Waiting for suggestions…
    @Michael_Oborne, @philip
    Thankyou
    Regards
    Yasir Khizar

May I know what camera are you using with Herelink?
Would it get stuck when taking photos?

Hi, @Alvin
We have used three cameras:

  1. Yangda Sky Eye-30 HZ 1080P (30x zoom)
  2. Yangda Sky Eye-I 1080P (10x zoom)
  3. Viewpro Z30TM 1080P (30x zoom)
    I wud like to mention that we have tried video recording with atleast 3 other herelinks and we have the same observation. The same was also observed with herelink old firmware. Since we have not been recording video nor taking pictures on-board i.e. air end at the camera side, so i have no experience but i think it is just a pwm signal based on which recording or pictures will be captured and has no relation to qgc ground end.
    Thanku
    Regards
    Yasir Khizar

Do you have any of the camera listed in the link below, so that you can test with your Herelink?

Just in case the problem came from camera

Dont have any of these cameras. But our vidwo streaming in herelink is nearly perfect… Just have the qgc app freezing problem when video recording button is pressed… I think it is not related with the camera… Did u test video recording feature from qgc extensively and can u say that it runs without issue?
Thanku
Regards
Yasir Khizar

We have tested the video recording feature in QGC. It works perfectly.

Do you have a HDMI-microHDMI cable to output video from computer? Such that you can test the video from elsewhere from camera.

You may also generate a bug report so that we could look into it
https://docs.cubepilot.org/user-guides/herelink/herelink-user-guides/generate-a-bug-report

Hello Alvin,

The whole QGC crashes - it is not a problem of the camera. When I do not record everithing works without problems.
It seems to be an issue of the data stream of the herlink and the recording in QGC: I only have problems when the link signal is weak - It seems that insability/gaps in the video datalink of the Helrelink causes QGC to crash.

In this case we need the bug report to understand what happened in the Herelink