Vibration values with hard mounted cube at the limit

Hi guys,

I need an advise regarding a vibration issue.

My setup is the following:

  • FC: Cube 2.1
  • DRON: Large copter 14000 coaxial Gryphon dynamics SP-U11 120kv-26inch folding prop

I have tested two ways to mount the cube onto the frame:

  • HARD MOUNT
  • WITH A EXTERNAL VIBRATION DAMPING (one which was heavily discourage by many people)

The following plots come from the same flight (an auto mission at 40 m altitude and 4m/s). The plots are the VIBES, CLIPS and FFT analysis from two mounting option. Here is the link for the plots:

https://drive.google.com/open?id=1B5Dl7BGFvnOsqYIxdorUDiCKDZLfOcwx

As you notice, WITH A EXTERNAL VIBRATION DAMPING, I get excellent performance in terms of vibration: average of 15 m/s2 on the VIBEs plots and 0 CLIP for the whole flight. With the HARD MOUNT option, is not thaaaat bad, I am getting an average of 30 m/s2 and a little jump on the CLIP0 at the end of the flight (however I have seen in other flights some jumps within the flight, but always below 100 and not regularly increasing).

ProfiCNC discourage the use of external vibration dampener due to an “horrible” cross-coupling that may happen. Looking at the performance of my setup hard mounted, do you recommend me to go ahead hard mounted? It concerned me a little that the VibeZ average is around 30 m/s2, with some pikes above, which is just the red line which may indicate vibration issues. Since I am just in the border of the acceptable value for the hard-mounted option… I don’t know what to do.

Hope you can help me decided guys,

Thanks,

JM

Looking at this data, I would say, hard mount it.

Yes, you have a vibration issue in your frame at ~80Hz, but your “isolation” solution has a vibration issue at 44Hz which is a better area to be in!

A few clips on landing is irrelevant.

Remember that your sensors are 16G… what you are looking for, is to know what is going on with the vehicle. If it has a vibration, that’s real data… if you isolate it out, you have removed the real data!

So please run Ardupilot Chibios latest release, EKF2, and enable all 3 IMU’s. (EK2_IMU_MASK to 7)

The EKF will select the best solution.

Is EKF3 enabled by default? Or how do i enable it? Do i need to calibrate over when enabling EKF3?

@juan.gonzalez We might have the same problem, hope somebody can help…

Kind regards.

more importantly… enable all three IMU’s

havn’t disabled any imu… :slight_smile: just curious if EKF3 is enabled by default

EK2_IMU_MASK to 7

but stick with EKF2 for now

EKF3 is still new, the important thing is EK2_IMU_MASK to 7

AND CHIBIOS ONLY!!!

DO NOT RUN Three EKFs on Nuttx!

1 Like

In fact ! The hard mount solution is the one that is at 44 HHz, and you are saying that it is a worse area to be in… Is that truth, or it was a typo?

it would help if I proofread my answers!

set EK2_IMU_MASK to 7, hard mount and enjoy flying!

1 Like

So does this advice to set EK2_IMU_MASK to 7 apply generally to all Cube aircraft running ChiBIOS? The default seems to be 3.

Yes, running all three IMU’s is how the system was designed, and having 3 EKF’s running in parallel gives the additional levels of safety

1 Like

so enable EKF3_ENABLE to 1?
default value is 0.

No. Leave it as zero

Set
EK2_IMU_MASK to 7

1 Like