HERE2 CAN issue

#1

Hello,

We got some issue with our HERE2 devices. We start by getting the prearm issue :
GPS 1: u-blox navigation rate configuration 0x1DFF
PreArm: GPS 1 failing configuration checks

To solve this,
We followed the procedure in HERE2 GPS failing configuration checks . We tried to configure the gps to can. It was not detected by the pixhawk (we tried several gps, several pixhawk, several carrier boards, and by applying the proposed parameters, then a little all the possible parameters, can, node id,…), without success…

Then we checked the boards’ uavcan by connecting a Zubax (no problem, it works very well : Uavcan ->pixhawk ok), then we used the usb can converter (BABEL) to see if here 2 is present on the bus (nothing on the can) -> Here 2 does not manage the can with its current firmware.

The proposed method is to flash by CAN, having the firmware and bootloader, we looked for another method to flash (via jtag and st-link -> stm32f3), we found the pinout of the jtag (similar to that of the carrier board - proficnc method - SM06B-SHLS-TF 6 pin connector), we flashed the bootloader (address 0x800000000) but not having the address at which the firmware starts, we preferred not to flash anything else). We tested on carrier board then on drone, the gps configuration problem is solved, no more problem reconfiguring the ublox here, we can arm… but!

The new problem is that the compass of here is no longer recognized… it is necessary to update also the rc3 firmware…

Impossible to use our here 2 in can, it is neither recognized under mission planner, nor under babel (with uavcan gui tool)) we tried again to flash through the can (with the bootloader updated in case or) unsuccessfully, we tried to find the address where the firmware should boot, or an alternative solution, without success.

We can we do ?

#2

@jschall

#3

I am having the problems getting Here2 to work on CAN also. Have tried all the settings in the setup guide from HEX to no avail. I have tried different CAN ports and settings in Params. Still nothing works. Changed cable on Here2 and configured for serial and I2C and it works, but if CAN is supposed to be better, I would rather get it working on CAN.


As you can see, I even went back to the version of Mission Planner that was used in the instructions as well as the closest I could get to the version of ArduCopter that they used.

With the latest Mission Planner and the latest Arduplane, I get the same results.

Where did I go wrong?

#4

you need to flash the 3.7 dev version to be able to configure the UAVCAN parameters. I had the same problem today :wink:

#5

Flash to here2 ? I can’t communicate with it.

I am trying to use it in plane actually

#6

Ardupilot version on the cube needs to be 3.7

#7

I am running plane. Latest beta download from website 3.10.0-DEV works

1 Like
#8

Got tired of trying to get everything to work correctly on CAN and swapped to I2C. I flashed to latest Rover to get all parameters back to default, then flashed to back to latest Plane, where the default configuration should work perfectly on I2C and it won’t arm because of GPS Configuration Rate error. What the world is going on? Yes I changed the switch in the Here2 Unit.

Can’t update this because it is not available on the CAN bus through the SLCan function.

Edit: I noticed that everytime I flash the latest copter firmware as described in the CAN Update Procedure, everything boots fine. as soon as I change the parameters to enable GPS on CAN (gps_type: 9), the cube locks up every time on boot. If I only change the CAN driver to 1 and reboot, I get an error in the messages that says: " Unable to get bus semaphore".

#9

@jschall @sidbh

#10

Will have to get this working on CAN in order to update it, or it will continue to report the GPS configuration error. Did you follow the instructions on the wiki to the letter? Once it is updated it should at least work on i2c/serial.

Will investigate why it is failing to get the semaphore. Do you have a log with LOG_DISARMED=1?

@Michael_Oborne we need to figure out how to make it easier for users to have success with the SLCAN interface…

#11

I followed the update instructions verbatim, even uninstalled the latest version of Mission Planner and installed the version used in the update procedure. The latest Copter firmware was downloaded from the link on the update procedure. I will have to check n the log_disarm=1. Let you know back later.
2 12-31-1969 6-00-00 PM.bin (2.2 MB)
2019-07-18 07-44-52.tlog (206.1 KB)

#12

After changing GPS_TYPE to 9, Pixhawk locks up and orange LED is lit under cube,only on the end closest to GPS and I2C ports of carrier board. Only difference in whats it’s doing from being in bootloader mode, is the other LED isn’t blinking orange.

When I try to connect, I get this:

#13

The fact that it says Proficnc cube F4 would indicate that you have the wrong drivers on mission planner.

It should say CubeBlack.

Firmware.ardupilot.org for mission planner.

Uninstall that driver first. Uninstall mission planner.

Then install mission planner from the .msi file

Makes sure to allow it to install all the drivers.

You need to accept them etc.

#14

The logs should still be on the SD card

#15

@Michael_Oborne?

#16

I already uninstalled that driver three times and it keeps coming back. I will try again.

#17

Uninstalled Mission Planner from Control Panel>Programs>Uninstall Programs. Went to Documents and Deleted the Mission Planner Folder. Then I checked under Users to make sure there wasn’t any Mission Planner files in there.

In Device Manager, I Right Clicked the ProfiCNC driver in Comports section and clicked Uninstall device and checked the box for uninstall driver and hit OK.

Then I went to c:\windows\system32\drivers and deletede usbser.sys, which is the driver that is associated with the ProfiCNC comport.

Downloaded the latest MSI Mission Planner and installed it.

Same results, only shows USB Serial Device.

Cube still locks up on boot with Here2 in CAN mode and CAN parameters set per your instructions and GPS on CAN2 on Cube Carrier board.

Still get a configuration error with Here2 in I2C mode.

#18

When you reinstalled Mission Planner, did it ask you to install drivers?

#19

Yes, it asked to install the drivers and i accepted it, then deleted that port along with the driver and went to c:\windows\system32\drivers and deleted it in there as well, again.

I had a Cube that I got in January and haven’t flown since the Service Bulletin 00002. I removed the new Cube from the Carrier Board and replaced it with the old Cube from January. This is the boot up messages with ArduPlane V3.9.8 (6ea22c9c).

All the CAN parameters were set per the Here2 instructions.
The error “Unable to get bus semaphore” isn’t there.

The SLCan doesn’t work either and the cube doesn’t recognise the Here2. “No GPS” in the HUD

#20

you deleted after the new drivers were installed? why?

and you need to be on ARDUPLANE 3.10 (MASTER) for SL CAN and allocation to work correctly